一、实验目的
掌握路由的宣告的方式
二、实验设备
Cisco 2811 3台、 串口数据线若干
三、实验拓扑
四、实验步骤
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Ethernet1/0
ip address 12.1.1.1 255.255.255.0
router ospf 110
network 1.1.0.0 0.0.255.255 area 0
network 12.1.1.0 0.0.0.255 area 0
ip route 3.3.3.0 255.255.255.0 12.1.1.2
R2:
interface Ethernet1/0
ip address 12.1.1.2 255.255.255.0
interface Ethernet1/1
ip address 23.2.2.2 255.255.255.0
router eigrp 90
redistribute ospf 110 metric 1000 100 255 5 1000
network 23.2.0.0 0.0.255.255
no auto-summary
router ospf 110
network 12.0.0.0 0.255.255.255 area 0
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Ethernet1/0
ip address 23.2.2.3 255.255.255.0
half-duplex
router eigrp 90
network 23.2.2.0 0.0.0.255
network 3.3.3.3 0.0.0.255
no auto-summary
R1:
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/56/88 ms
R1#ping 3.3.3.3 sou
R1#ping 3.3.3.3 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/101/308 ms
R1#trac
R1#traceroute 3.3.3.3 so
R1#traceroute 3.3.3.3 source 1.1.1.1
Type escape sequence to abort.
Tracing the route to 3.3.3.3
1 12.1.1.2 44 msec 36 msec 20 msec
2 23.2.2.3 52 msec * 56 msec
R1#ping 23.2.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.2.2.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
3.0.0.0/24 is subnetted, 1 subnets
S 3.3.3.0 [1/0] via 12.1.1.2
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Ethernet1/0
R2:
R2#h
*Mar 1 00:15:48.443: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/11] via 12.1.1.1, 00:12:25, Ethernet1/0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/409600] via 23.2.2.3, 00:03:36, Ethernet1/1
23.0.0.0/24 is subnetted, 1 subnets
C 23.2.2.0 is directly connected, Ethernet1/1
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Ethernet1/0
R3:
R3#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
D EX 1.1.1.1 [170/2611200] via 23.2.2.2, 00:11:09, Ethernet1/0
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
C 23.2.2.0 is directly connected, Ethernet1/0
12.0.0.0/24 is subnetted, 1 subnets
D EX 12.1.1.0 [170/2611200] via 23.2.2.2, 00:11:09, Ethernet1/0
R3#ping 1.1.1.1 source 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 3.3.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/50/72 ms
R3#ping 12.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
本文出自 “简爱196” 博客,谢绝转载!