一、实验拓扑
二、设置路由器IP
R1:
R1(config)#int s0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#no shut
R2:
R2(config)#int s0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#no shut
R2(config)#int s0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no shut
R3:
R3(config)#int s0/0
R3(config-if)#ip add 23.23.23.3 255.255.255.0
R3(config-if)#no shut
配置完成后测试直连网络的连通性
R1:
R1#ping 12.12.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms
R2:
R2#ping 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms
R2#ping 23.23.23.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/6 ms
R3:
R3#ping 23.23.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms
直连网络连接成功!
三、配置EIGRP
1、在三台路由器上的开启换回接口
R1:
R1(config)#int loopback 0
R1(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip add 1.1.1.1 255.255.255.0
R2:
R2(config)#int loopback 0
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#
R2(config-if)#ip add 2.2.2.2 255.255.255.0
R3:
R3(config)#int loopback 0
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#
R3(config-if)#ip add 3.3.3.3 255.255.255.0
2、配置EIGRP---------注意使用反掩码和不使用反掩码的区别
R1:
R1(config)#router eigrp 100
R1(config-router)#network 12.12.12.0 0.0.0.255
R1(config-router)#network 1.0.0.0
R1(config-router)#
R2:
R2(config)#router eigrp 100
R2(config-router)#network 12.12.12.0 0.0.0.255
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 12.12.12.1 (Serial0/0) is up: new adjacency
R2(config-router)#network 2.2.2.0 0.0.0.255
R2(config-router)#network 23.23.23.0 0.0.0.255
R3:
R3(config)#router eigrp 100
R3(config-router)#network 23.23.23.0 255.255.255.0
R3(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 23.23.23.2 (Serial0/0) is up: new adjacency
R3(config-router)#network 3.3.3.0 0.0.0.255
EIGRP已经成功开启,下面使用show ip protocol 来查看下配置的正确性
R1:
R1(config-router)#do show ip pro
Routing Protocol is "eigrp 100 "
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
Automatic network summarization is in effect
Automatic address summarization:
1.0.0.0/8 for Serial0/0
Summarizing with metric 128256
12.0.0.0/8 for Loopback0
Summarizing with metric 20512000
Maximum path: 4
Routing for Networks:
12.12.12.0/24
1.0.0.0
Routing Information Sources:
Gateway Distance Last Update
12.12.12.2 90 1148582
Distance: internal 90 external 170
在三台路由器上使用show ip route 命令来查看路由表
R1:
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 1.0.0.0/8 is a summary, 00:09:45, Null0
C 1.1.1.0/24 is directly connected, Loopback0
D 2.0.0.0/8 [90/20640000] via 12.12.12.2, 00:07:50, Serial0/0
D 3.0.0.0/8 [90/21152000] via 12.12.12.2, 00:04:09, Serial0/0
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 12.0.0.0/8 is a summary, 00:09:45, Null0
C 12.12.12.0/24 is directly connected, Serial0/0
D 23.0.0.0/8 [90/21024000] via 12.12.12.2, 00:07:36, Serial0/0
由以上信息可以看出,EIGRP已经正确配置
3、关闭EIGRP自动汇总动能
R1(config-router)#no auto-summary
R2(config-router)#no auto-summary
R3(config-router)#no auto-summary
再次使用show ip route 命令查看路由表区别
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/20640000] via 12.12.12.2, 00:01:37, Serial0/0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/21152000] via 12.12.12.2, 00:01:12, Serial0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial0/0
23.0.0.0/24 is subnetted, 1 subnets
D 23.23.23.0 [90/21024000] via 12.12.12.2, 00:01:37, Serial0/0
可以看出已经取消了自动汇总
4、在R3上使用手动汇总
R3(config-if)#ip summary-address eigrp 100 3.3.0.0 255.255.0.0
在R1使用show ip route 来查看R3的路由表信息已经变化
R1:
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/20640000] via 12.12.12.2, 00:05:41, Serial0/0
3.0.0.0/16 is subnetted, 1 subnets
D 3.3.0.0 [90/21152000] via 12.12.12.2, 00:01:23, Serial0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial0/0
23.0.0.0/24 is subnetted, 1 subnets
D 23.23.23.0 [90/21024000] via 12.12.12.2, 00:05:41, Serial0/0
R1(config-router)#
5、使用debug命令
先使用unbug all命令,方便以后可以快速关闭debug命令
R1#un all
All possible debugging has been turned off
R1#debug ip eigrp