使用Esp-des加密算法

使用Esp-des加密算法
VPDN 路由器 1 配置:
----------------------------------------------------------------------------------------------
config t
! 进入全局配置模式
hostname Router1
! 设置主机名为 Router1
access-list 100 permit i p 10.32.1 .0 0.0.0.255 10.32.2.0 0.0.0.255
! 创建加密访问控制列表 ACL100 ,保护 10.32.1 .0/24 10.32.2.0/24 网段之间的通信
crypto ipsec transform-set rtsc  esp-des
! 定义变换集合 rtsc ,使用 esp-des 加密算法
 exit
!
crypto map rtsc-map 10 ipsec-manual
! 创建加密映射条目 rtsc-map ,映射序列号为 10 ,指定手工方式建立安全联盟
 set peer 192.168.33.39
 ! 指定远端 IPSec 同位体地址 192.168.33.39
 set session-key inbound esp 260 cipher 0123456789abcdef
 ! 入站安全参数索引 SPI 260 密码为 0123456789abcdef
 set session-key outbound esp 261 cipher 0123456789abcdef
 ! 出站安全参数索引 SPI 261 密码为 0123456789abcdef
 set transform-set rtsc
 ! 指定使用的变换集合 rtsc
 match address 100
 ! 指定匹配的 ACL ,标识受 IPSec 保护的通信范畴
 exit
!
interface FastEthernet 1/0
 ip address 192.168.33.40 255.255.255.0
 ! 设置接口 IP 地址 192.168.33.40/24
 crypto map rtsc-map
 ! 在此接口上应用加密映射条目 rtsc-map
 no shutdown
 ! 启用接口
 exit
!
interface FastEthernet 1/1
 ip address 10.32.1 .1 255.255.255.0
 ! 设置接口 IP 地址 10.32.1 .1/24
 no shutdown
 ! 启用接口
 exit
!
ip route 10.32.2 .0 255.255.255.0 192.168.33.39
! 添加静态路由,目的地址 10.32.2 .0/24 ,下一跳指向 192.168.33.39 即对端 IPSec 同位体地址
line vty 0 4
! 设置 vty 0-4 的密码 telnet 口令
 login
 password 0 star
 ! telnet 口令设置为 star
 exit
end
write
! 保存配置
 
 
VPDN 路由器 2 配置
----------------------------------------------------------------------------------------------
config t
! 进入全局配置模式
hostname Router2
! 设置主机名为 Router2
access-list 100 permit i p 10.32.2 .0 0.0.0.255 10.32.1.0 0.0.0.255
! 创建加密访问控制列表 ACL100 ,保护 10.32.2 .0/24 10.32.1.0/24 网段之间的通信
crypto ipsec transform-set rtsc  esp-des
! 定义变换集合 rtsc ,使用 esp-des 加密算法
 exit
!
crypto map rtsc-map 10 ipsec-manual
! 创建加密映射条目 rtsc-map ,映射序列号为 10 ,指定手工方式建立安全联盟
 set peer 192.168.33.40
 ! 指定远端 IPSec 同位体地址 192.168.33.40
 set session-key inbound esp 261 cipher 0123456789abcdef
 ! 入站安全参数索引 SPI 261 密码为 0123456789abcdef
 set session-key outbound esp 260 cipher 0123456789abcdef
 ! 出站安全参数索引 SPI 260 密码为 0123456789abcdef
 set transform-set rtsc
 ! 指定使用的变换集合 rtsc
 match address 100
 ! 指定匹配的 ACL ,标识受 IPSec 保护的通信范畴
 exit
!
interface FastEthernet 1/0
ip address 192.168.33.39 255.255.255.0
 ! 设置接口 IP 地址 192.168.33.39/24
 crypto map rtsc-map
 ! 在此接口上应用加密映射条目 rtsc-map
 no shutdown
 ! 启用接口
 exit
!
interface FastEthernet 1/1
ip address 10.32.2 .1 255.255.255.0
 ! 设置接口 IP 地址 10.32.2 .1/24
 no shutdown
 ! 启用接口
 exit
!
ip route 10.32.1 .0 255.255.255.0 192.168.33.40
! 添加静态路由,目的地址 10.32.1 .0/24 ,下一跳指向 192.168.33.40 即对端 IPSec 同位体地址
line vty 0 4
! 设置 vty 0-4 的密码 telnet 口令
 login
 password 0 star
 ! telnet 口令设置为 star
 exit
end
write
! 保存配置

你可能感兴趣的:(职场,休闲,路由交换)