4.9 Frame-Relay&EIGRP
实验目的:
1、掌握帧中继上部署EIGRP。
2、通过部署EIGRP实现不同分支之间的通信。
3、理解帧中继子接口,包括点对点和多点子接口。
实验拓扑:
实验步骤:
1、依据图中拓扑,通过路由器模拟帧中继交换机,配置如下:
①开启帧中继交换功能
FW-SW(config)#frame-relay switching
②接口开启帧中继封装,并定义为DCE接口
FW-SW(config)#int s0/0
FW-SW(config-if)#no shutdown
FW-SW(config-if)#encapsulation frame-relay
FW-SW(config-if)#frame-relay intf-type dce
FW-SW(config-if)#exit
FW-SW(config)#int s0/1
FW-SW(config-if)#no shutdown
FW-SW(config-if)#encapsulation frame-relay
FW-SW(config-if)#frame-relay intf-type dce
FW-SW(config-if)#exit
FW-SW(config)#int s0/2
FW-SW(config-if)#no shutdown
FW-SW(config-if)#encapsulation frame-relay
FW-SW(config-if)#frame-relay intf-type dce
FW-SW(config-if)#exit
③编写帧中继转发条目
FW-SW(config)#int s0/0
FW-SW(config-if)#frame-relay route 102 interface s0/1 201
FW-SW(config-if)#frame-relay route 103 interface s0/0 301
FW-SW(config-if)#exit
FW-SW(config)#int s0/1
FW-SW(config-if)#frame-relay route 201 interface s0/0 102
FW-SW(config-if)#exit
FW-SW(config)#int s0/2
FW-SW(config-if)#frame-relay route 301 interface s0/0 103
FW-SW(config-if)#exit
2、通过部署帧中继技术,使得各个站点直连连通,其中R1为中心点,R2和R3为分支点,配置如下:
R1上
R1(config)#int s0/0
R1(config-if)#no shutdown
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#frame-relay map ip 192.168.1.2 102 broadcast
R1(config-if)#frame-relay map ip 192.168.1.3 103 broadcast
R1(config-if)#exit
R2上
R2(config)#int s0/0
R2(config-if)#no shutdown
R2(config-if)#encapsulation frame-relay
R2(config-if)#no frame-relay inverse-arp
R2(config-if)#frame-relay map ip 192.168.1.1 201 broadcast
R2(config-if)#frame-relay map ip 192.168.1.3 201 broadcast
R2(config-if)#exit
R3上
R3(config)#int s0/0
R3(config-if)#no shutdown
R3(config-if)#encapsulation frame-relay
R3(config-if)#no frame-relay inverse-arp
R3(config-if)#frame-relay map ip 192.168.1.1 301 broadcast
R3(config-if)#frame-relay map ip 192.168.1.2 301 broadcast
R3(config-if)#exit
测试直连连通性,如下:
R1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/42/60 ms
R1#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/31/52 ms
R2#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/68/96 ms
可以看到,直连连通没有问题。
3、部署EIGRP路由协议,配置如下:
R1上
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.1.0
R1(config-router)#network 1.0.0.0
R1(config-router)#exit
R2上
R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.1.0
R2(config-router)#network 2.0.0.0
R2(config-router)#exit
R3上
R3(config)#router eigrp 100
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.1.0
R3(config-router)#network 3.0.0.0
R3(config-router)#exit
此时查看路由表,如下:
R1上
R1#show ip route eigrp
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 192.168.1.2, 00:02:40, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2297856] via 192.168.1.3, 00:00:26, Serial0/0
R2上
R2#show ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.1.1, 00:02:47, Serial0/0
R3上
R3#show ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.1.1, 00:02:43, Serial0/0
可以看到,中心点R1可以学到R2和R3的路由条目,但是分支点R2和R3之间没有相互学到对方路由,这是由接口的水平分割特性所造成的:“从本接口学到的路由条目不会从本接口发送出去。”为了解决由水平分割所导致的路由信息不同步问题,可以有两种解决方案:
①接口下关闭水平分割
②创建逻辑子接口
4、关闭接口水平分割特性,使得分支之间相互学习到路由,配置如下:
R1(config)#int s0/0
R1(config-if)#no ip split-horizon eigrp 100[PL1]
查看R2和R3上面的路由表
R2#show ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.1.1, 00:15:12, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2809856] via 192.168.1.1, 00:00:36, Serial0/0
R3#show ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.1.1, 00:15:06, Serial0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2809856] via 192.168.1.1, 00:00:39, Serial0/0
此时,分支之间相互学习到路由。
5.创建逻辑子接口,将不同的PVC映射到子接口,其中R1和R2处在192.168.1.0/24网段,R1和R3处在192.168.2.0/24网段,配置如下:
R1上
R1(config)#default int s0/0[PL2]
R1(config)#int s0/0
R1(config-if)#encapsulation frame-relay
R1(config)#int s0/0.1 point-to-point[PL3]
R1(config-subif)#ip address 192.168.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 102[PL4]
R1(config-fr-dlci)#exit
R1(config)#int s0/0.2 point-to-point
R1(config-subif)#ip add 192.168.2.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 103
R1(config-fr-dlci)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.2.0
R1(config-router)#exit
R3上
R3(config)#int s0/0
R3(config-if)#ip address 192.168.2.3 255.255.255.0
R3(config-if)#frame-relay map ip 192.168.2.1 301 broadcast[PL5]
R3(config)#router eigrp 100
R3(config-router)#network 192.168.2.0
R3(config-router)#exit
再次查看R2和R3的路由表,如下:
R2#show ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.1.1, 00:08:10, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2809856] via 192.168.1.1, 00:05:10, Serial0/0
D 192.168.2.0/24 [90/2681856] via 192.168.1.1, 00:05:13, Serial0/0
R3#show ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.2.1, 00:05:15, Serial0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2809856] via 192.168.2.1, 00:05:15, Serial0/0
D 192.168.1.0/24 [90/2681856] via 192.168.2.1, 00:05:15, Serial0/0
可以看到,通过部署逻辑子接口,分支之间可以相互学习到对方路由。此实验完成。
[PL1]接口下关闭水平分割时必须加入EIGRP进程,否则无效。
[PL2]初始化接口配置
[PL3]帧中继子接口分两种:
1.点对点子接口;
2.多点子接口;
其中点对点子接口主要用于点对点拓扑环境,而多点子接口与帧中继主接口类似,可以用于多路访问环境。
[PL4]点对点子接口的映射不需要对方IP地址,只需要映射本端DLCI即可。
[PL5]重新映射。
==========================================
PingingLab・高品质IT教育提供商
CCIE 实验室・IT项目实战・高端人才定制
深圳拼客信息科技有限公司・广州大学城外环西路站
新浪微博:@拼客科技PingingLab @PingingLab-陈鑫杰
PingingLab微信公众号:pinginglab
PingingLab技术交流群:240920680