hostname R1
no ip domain lookup
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface Serial1/0
ip address 192.1.1.1 255.255.255.0
encapsulation frame-relay
//在这里虽然配置了frame-relay map ip,但是,通过返向地址解释,依
//然可以获得到达对方的DLCI,因为在帧中继交换机上配置了PVC
frame-relay map ip 192.1.1.2 100
frame-relay map ip 192.1.1.3 200
frame-relay lmi-type ansi
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 192.1.1.0 0.0.0.255 area 0
由于是非广播型的NBMA,所以要在HUB上指定neighbor
neighbor 192.1.1.2
neighbor 192.1.1.3
R2#show ip ospf inter s 1/0
Serial1/0 is up, line protocol is up
Internet Address 192.1.1.2/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64 //可以看到接口的类型为非广播类型的
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 2.2.2.2, Interface address 192.1.1.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:27
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)
R1#show ip ospf neig
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/DROTHER 00:01:43 192.1.1.2 Serial1/0
3.3.3.3 0 FULL/DROTHER 00:01:49 192.1.1.3 Serial1/0
!
hostname R2
!
no ip domain lookup
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial1/0
ip address 192.1.1.2 255.255.255.0
encapsulation frame-relay
//将接口的优先级配置为0,使他不参与DR和BDR的选举
ip ospf priority 0
frame-relay map ip 192.1.1.1 100 //这一句其实可以不配,因为在帧中继交换机上已经配置了PVC,可以通过返向ARP获取DLCI 号
frame-relay map ip 192.1.1.3 100 //这一句必须配置,在帧中继交换机上没有配置,为了解决MA的下一跳问题,必须指定到达R3的DLCI号
frame-relay lmi-type ansi
R2#show frame-relay map
Serial1/0 (up): ip 192.1.1.1 dlci 100(0x64,0x1840), static,
CISCO, status defined, active
Serial1/0 (up): ip 192.1.1.3 dlci 100(0x64,0x1840), static,
CISCO, status defined, active
R2#show ip route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 192.1.1.1, 00:28:43, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 192.1.1.3, 00:28:43, Serial1/0
C 192.1.1.0/24 is directly connected, Serial1/0
hostname R3
!
no ip domain lookup
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial1/0
ip address 192.1.1.3 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
serial restart-delay 0
no fair-queue
frame-relay map ip 192.1.1.1 200
frame-relay map ip 192.1.1.2 200
frame-relay lmi-type ansi
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.1.1.0 0.0.0.255 area 0
R3#show frame-relay map
Serial1/0 (up): ip 192.1.1.1 dlci 200(0xC8,0x3080), static,
CISCO, status defined, active
Serial1/0 (up): ip 192.1.1.2 dlci 200(0xC8,0x3080), static,
CISCO, status defined, active
R3#show ip route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 192.1.1.2, 00:30:18, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 192.1.1.1, 00:30:18, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
C 192.1.1.0/24 is directly connected, Serial1/0
本文出自 “xiaomu205.com” 博客,转载请与作者联系!