验证RIP被动接口只收不发的正确性

1.实验目的:验证RIP被动接口只收不发的正确性
2.实验拓扑:R1的s2/1 和 R2的s2/1相连
3.配置命令:
R1上的配置(未启动被动接口前的配置)
R1(config-line)#int loo 1
R1(config-if)#ip add 1.1.1.1 255.255.255.0
R1(config-if)#int s2/1
R1(config-if)#ip add 12.0.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#router rip                //启动rip进程
R1(config-router)#version 1           //版本为version 1
R1(config-router)#network 1.0.0.0    //宣告1.0.0.0 ,并且激活接口
R1(config-router)#network 12.0.0.0  //宣告12.0.0.0 ,并且激活接口
R2上的配置(未启动被动接口前的配置)
R2(config)#int loo 2
R2(config-if)#ip add 2.2.2.2 255.255.255.0
R2(config-if)#int s2/1
R2(config-if)#ip add 12.0.0.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#router rip
R2(config-router)#version 1
R2(config-router)#network 2.0.0.0
R2(config-router)#network 12.0.0.0
R1上的配置(启动被动接口时的配置)
R1(config-line)#int loo 1
R1(config-if)#ip add 1.1.1.1 255.255.255.0
R1(config-if)#int s2/1
R1(config-if)#ip add 12.0.0.1 255.255.255.0
R1(config-if)#no shut
R1(config)#int f0/0
R1(config-if)#ip add 3.3.3.3 255.255.255.0
R1(config-if)#no shut
R1(config-if)#router rip                //启动rip进程
R1(config-router)#version 1           //版本为version 1
R1(config-router)#network 1.0.0.0    //宣告1.0.0.0 ,并且激活接口
R1(config-router)#network 12.0.0.0  //宣告12.0.0.0 ,并且激活接口
R1(config-router)#network  3.0.0.0 //宣告3.0.0.0 ,并且激活接口
R1(config-router)#passive-interface f0/0 //启动被动接口
R2上的配置(启动被动接口时的配置)
R2(config)#int loo 2
R2(config-if)#ip add 2.2.2.2 255.255.255.0
R2(config-if)#int s2/1
R2(config-if)#ip add 12.0.0.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#router rip
R2(config-router)#version 1
R2(config-router)#network 2.0.0.0
R2(config-router)#network 12.0.0.0
4.实验分析:
未启动之前的现象:
R1#debug ip rip
RIP protocol debugging is on
00:13:06: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (3.3.3.3)
00:13:06: RIP: build update entries
00:13:06:       network 1.0.0.0 metric 1
00:13:06:       network 2.0.0.0 metric 2
00:13:06:       network 12.0.0.0 metric 1
00:13:06: RIP: sending v1 update to 255.255.255.255 via Serial2/1 (12.0.0.1)
00:13:06: RIP: build update entries
00:13:06:       network 1.0.0.0 metric 1
00:13:06:       network 3.0.0.0 metric 1
00:13:06: RIP: sending v1 update to 255.255.255.255 via Loopback1 (1.1.1.1)
00:13:06: RIP: build update entries
00:13:06:       network 2.0.0.0 metric 2
00:13:06:       network 3.0.0.0 metric 1
00:13:06:       network 12.0.0.0 metric 1
00:13:17: RIP: received v1 update from 12.0.0.2 on Serial2/1
00:13:17:      2.0.0.0 in 1 hops
启动被动接口之后的现象:
R1#debug ip rip
RIP protocol debugging is on
R1#
00:17:21: RIP: received v1 update from 12.0.0.2 on Serial2/1
00:17:21:      2.0.0.0 in 1 hops
R1#
00:17:41: RIP: sending v1 update to 255.255.255.255 via Serial2/1 (12.0.0.1)
00:17:41: RIP: build update entries
00:17:41:       network 1.0.0.0 metric 1
00:17:41:       network 3.0.0.0 metric 1
00:17:41: RIP: sending v1 update to 255.255.255.255 via Loopback1 (1.1.1.1)
00:17:41: RIP: build update entries
00:17:41:       network 2.0.0.0 metric 2
00:17:41:       network 3.0.0.0 metric 1
00:17:41:       network 12.0.0.0 metric 1
通过比较我们发现,启动被动接口之后少了这样一条信息:
00:13:06: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (3.3.3.3)
00:13:06: RIP: build update entries
00:13:06:       network 1.0.0.0 metric 1
00:13:06:       network 2.0.0.0 metric 2
00:13:06:       network 12.0.0.0 metric 1而这些就是所谓的发(f0/0现在只通过广播received,而不sending),我们期望的结果是正确的

你可能感兴趣的:(接口,验证,休闲,rip,正确性)