_____
|第二章|
------
路由选择协议的分类
可路由协议(routed protocol)如:IP IPX appletalk
路由选择协议(routing protocol)如:RIP(路由信息协议) IGRP (内部网关选择协议)
路由表 (静态路由/动态路由)
动态路由协议的分类
按算法:距离矢量,链路状态,混合算法
发送子网掩码与否:有类(RIP,IGRP),无类
网络规模:IGP EGP
自治系统 (使用相同准则的网络的集合)
IGP在一个自治系统内运行
egp连接不同的自治系统
反应路由协议性能的参数
收敛时间convergence time(网络拓补变化到所有路由知道这个变化的时间)
管理距离(反应准确度和可信度,越小越可信)
一部分表格如下:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
route source路由源 ~ default distance默认距离值 ~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
connected interface直连接口 ~ 0 ~
static 静态路由 ~ 1 ~
externalBGP 外部BGP ~ 20 ~
internal BGP 内部BGP ~ 200 ~
internalEIGRP 内部GIGRP ~ 90 ~
RIPv1,RIPv2 ~ 12 ~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
RIP V2特性
RIP v2的基本配置
RIP v2实现VLSM希望划分
RIP v2实现CIDR路由汇总
RIP 2实现等跳路径的负载均衡
RIP2认证配置
RIP2配置被动接口抑制路由更新
RIP的工作原理
广播方式周期性的通告路由表
互通有无
最大跳数15跳,最少跳为最佳路径,路由跳数多于15时候,认为网络不可达(适用于小型网络)
存在路由环路为题
RIP v2特性
组播替代广播路由条目
支持MD5认证路由条目
无类的路由协议
路由条目中携带子网掩码支持VLSM
支持CIDR
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
RIPv1 RIPv2
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
路由更新中不携带子网信息 更新中携带路由信息
不提供认证 提供明文和MD5认证
不支持VLSM和CIDR 支持VLSM和CIDR
采用广播更新 采用组播(224.0.0.9)更新
有类别(classful)路由协议 无类别(classless)路由协议
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
RIPv2的配置命令
router(config)#router rip 启动rip进程
router(config-router)# version 2 关闭version1,开启version2
router(config-router)# network network-number 发布网络
实例:
网络拓补描述:
-----(fa1/0)R1(s0/0)------(s0/0)R2(s1/1)----(s0/0)R3(fa1/0)-----
201.1 202.1 202.2 203.1 203.2 204.1
R1: f1/0 201.0.0.1/24
s0/0 202.0.0.1/24
R2: s0/0 202.0.0.2/24
s0/1 203.0.0.1/24
R3 s0/0 203.0.0.2/24
f1/0 204.0.0.1/24
---------------------------------------------------------------------
命令脚本如下:
R1
-------------------------
en
conf t
hostname R1
ip classless
ip subnet-zero
no ip demain-lookup
int f1/0
ip add 201.0.0.1 255.255.255.0
no shu
exi
int s0/0
ip add 202.0.0.1 255.255.255.0
no shu
end
sh ip int b
--------------------------------
R2
-------------------------
en
conf t
hostname R2
ip classless
ip subnet-zero
no ip demain-lookup
int s0/0
ip add 202.0.0.2 255.255.255.0
no shu
exi
int s0/1
ip add 203.0.0.1 255.255.255.0
no shu
end
sh ip int b
-----------------------------------
R3
-------------------------
en
conf t
hostname R3
ip classless
ip subnet-zero
no ip demain-lookup
int f1/0
ip add 204.0.0.1 255.255.255.0
no shu
exi
int s0/0
ip add 203.0.0.2 255.255.255.0
no shu
end
sh ip int b
--------------------------------------
依次粘贴到各个路由上面
RIP的配置
对R1:
en
conf t
router rip
version 2
network 201.0.0.0
network 202.0.0.0
end
sh ip protocols
sh ip rou
对于R2:
en
conf t
router rip
version 2
network 202.0.0.0
network 203.0.0.0
end
sh ip protocols
sh ip rou
对于R3:
en
conf t
router rip
version 2
network 203.0.0.0
network 204.0.0.0
end
sh ip protocols
sh ip route
RIP v1和RIP v2的兼容性(version 1可以接受version1 2,version2只能接受version2)
router(config-if)#ip rip send version 1 2 声明发送版本的信息
router(config-if)#ip rip receive version 1 2 声明接受版本的信息
例如:
en
conf t
int s 0/0
ip rip send version 1 2
ip rip receive version 1 2
end
sh ip protocols
路由汇总:
~~~~~~~~~~~~~~~~~~~`
取消路由汇总:
en
conf t
router rip
no auto-summary
启用路由汇总:
en
conf t
interface s0/0
ip summary-address rip 202.0.0.0 255.255.255.0
显示路由表
~~~~~~~~~~~~~~~~~~~~~
sh ip route
其中,开头R表示RIP方式获取到的
C表示直连
有多个路由条目时候,选择掩码长的条目.掩码越长,路由越准确