EIGRP汇总时Leak-map 的使用

实验目的
掌握如何使用leak-map泄漏部分精确路由,具体要求:R1、R6 之间运行EIGRP 协议,R1 在向R6通过路由时候进行路由汇总,将192.168.1.0、192.168.2.0、192.168.3.0 汇总为192.168.0.0/22的一条路由,但是R1上要向R6单独通告一个192.168.1.0/24的精确路由。
实验拓扑
 

\ 实验配置
1、路由器R1
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
!
interface Serial0/1
 ip address 16.16.16.1 255.255.255.0
 ip summary-address eigrp 90 192.168.0.0 255.255.252.0 5 leak-map myleakmap
!
router eigrp 90
 network 16.16.16.0 0.0.0.255
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 auto-summary
!
ip access-list standard myleakmapacl
 permit 192.168.1.0 0.0.0.255
!
route-map myleakmap permit 10
 match ip address myleakmapacl
!
2、路由器R6
interface Serial0/1
 ip address 16.16.16.6 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
router eigrp 90
 network 16.16.16.0 0.0.0.255
 no auto-summary
!

 实验验证
没有配置myleakmap时
R6#show ip route
Gateway of last resort is not set


     16.0.0.0/24 is subnetted, 1 subnets
C       16.16.16.0 is directly connected, Serial0/1
D    192.168.0.0/22 [90/2297856] via 16.16.16.1, 00:01:26, Serial0/1
配置myleakmap之后
R6#show ip route
Gateway of last resort is not set

     16.0.0.0/24 is subnetted, 1 subnets
C       16.16.16.0 is directly connected, Serial0/1
D    192.168.1.0/24 [90/2297856] via 16.16.16.1, 00:00:04, Serial0/1
D    192.168.0.0/22 [90/2297856] via 16.16.16.1, 00:01:35, Serial0/1
可以看到,R6上已经出现了192.168.1.0/24 的精确路由。

你可能感兴趣的:(EIGRP,leak-map)