1、基本配置(交换机、路由器安全登陆管理、端口连接描述、配置vlan1地址)
Username pinginglab password ccnp
Enable password cisco
Line console 0
Login local
Logging synchronous
Exec-timeout 0 0
Line vty 0 4
Login local
Transport input ssh
Transport output ssh
Line vty 5 15
Transport input none
Transport output none
int f0/1
Description sw3
Int vlan 1
No sh
Ip add 192.168.1.1 255.255.255.0
2、vlan配置(trunk、vtp、stp)
Int rang f0/2 - 5
Switchport trunk encapsulation dot1q
Switchport mode trunk
Switchport trunk allowed vlan 1,1002-1005,10,20,30,40,50,60,70,80
Vtp domain PL
Vtp password pinginglab
Vtp mode server
Vtp version 2
Vtp pruning
Vtp domain PL
Vtp password pinginglab
Vtp mode client
Vlan 10 name TT
Vlan 20 name HR
Vlan 30 name IT
Vlan 40 name Slaes
Vlan 50 name DQ
Vlan 60 name EQ
Vlan 70 name YY
Vlan 80 name YOU
spanning-tree vlan 20 root primary
spanning-tree vlan 40 root primary
spanning-tree vlan 60 root primary
spanning-tree vlan 80 root primary
spanning-tree vlan 10 root secondary
spanning-tree vlan 30 root secondary
spanning-tree vlan 50 root secondary
spanning-tree vlan 70 root secondary
3、三层(Etherchannel)技术
int range f0/23 - 24
no switchport
no sh
channel-group 1 mode on
int port-channel 1
ip add 172.16.30.2 255.255.255.0
4、网关冗余配置(hsrp)
int vlan 10
no sh
ip add 192.168.10.252 255.255.255.0
standby 10 ip 192.168.10.254
standby 10 priority 100
int vlan 20
no sh
ip add 192.168.20.253 255.255.255.0
standby 20 ip 192.168.20.254
int vlan 30
no sh
ip add 192.168.30.252 255.255.255.0
standby 30 ip 192.168.30.254
standby 30 priority 100
int vlan 40
no sh
ip add 192.168.40.253 255.255.255.0
standby 40 ip 192.168.40.254
standby 40 priority 200
int vlan 50
no sh
ip add 192.168.50.252 255.255.255.0
standby 50 ip 192.168.50.254
standby 50 priority 100
int vlan 60
no sh
ip add 192.168.60.253 255.255.255.0
standby 60 ip 192.168.60.254
standby 60 priority 200
int vlan 70
no sh
ip add 192.168.70.252 255.255.255.0
standby 70 ip 192.168.70.254
standby 70 priority 100
int vlan 80
no sh
ip add 192.168.80.253 255.255.255.0
standby 80 ip 192.168.80.254
standby 80 priority 200
4、DHCP
Ip dhcp pool vlan10
Network 192.168.10.0 255.255.255.0
Default-router 192.168.10.254
Dns-server 8.8.8.8
Ip dhcp pool vlan20
Network 192.168.20.0 255.255.255.0
Default-router 192.168.20.254
Dns-server 8.8.8.8
Ip dhcp pool vlan30
Network 192.168.30.0 255.255.255.0
Default-router 192.168.30.254
Dns-server 8.8.8.8
Ip dhcp pool vlan40
Network 192.168.40.0 255.255.255.0
Default-router 192.168.40.254
Dns-server 8.8.8.8
Ip dhcp pool vlan50
Network 192.168.50.0 255.255.255.0
Default-router 192.168.50.254
Dns-server 8.8.8.8
Ip dhcp pool vlan60
Network 192.168.60.0 255.255.255.0
Default-router 192.168.60.254
Dns-server 8.8.8.8
Ip dhcp pool vlan70
Network 192.168.70.0 255.255.255.0
Default-router 192.168.70.254
Dns-server 8.8.8.8
Ip dhcp pool vlan80
Network 192.168.80.0 255.255.255.0
Default-router 192.168.80.254
Dns-server 8.8.8.8
ip dhcp excluded-address 192.168.10.253
ip dhcp excluded-address 192.168.10.252
ip dhcp excluded-address 192.168.10.254
ip dhcp excluded-address 192.168.20.253
ip dhcp excluded-address 192.168.20.252
ip dhcp excluded-address 192.168.20.254
ip dhcp excluded-address 192.168.30.253
ip dhcp excluded-address 192.168.30.252
ip dhcp excluded-address 192.168.30.254
ip dhcp excluded-address 192.168.40.253
ip dhcp excluded-address 192.168.40.252
ip dhcp excluded-address 192.168.40.254
ip dhcp excluded-address 192.168.50.253
ip dhcp excluded-address 192.168.50.252
ip dhcp excluded-address 192.168.50.254
ip dhcp excluded-address 192.168.60.253
ip dhcp excluded-address 192.168.60.252
ip dhcp excluded-address 192.168.60.254
ip dhcp excluded-address 192.168.70.253
ip dhcp excluded-address 192.168.70.252
ip dhcp excluded-address 192.168.70.254
ip dhcp excluded-address 192.168.80.253
ip dhcp excluded-address 192.168.80.252
ip dhcp excluded-address 192.168.80.254
5、动态路由协议(EIGRP或OSPF)
Router eigrp 65003
No auto-summary
Network 172.16.0.0 0.0.255.255
Network 192.168.0.0 0.0.255.255
Network 1.1.1.0 0.0.0.255
Network 0.0.0.0 255.255.255.255
ip route 0.0.0.0 0.0.0.0 s0/1/0
redistribute static
router ospf 100
router-id 10.10.10.10
network 172.16.10.0 0.0.0.255 area 0
network 172.16.30.0 0.0.0.255 area 0
network 192.168.0.0 0.0.255.255 area 0
default-information originate
6、地址转换(PAT、NAT)
access-list 10 permit 192.168.10.0 255.255.255.0
access-list 10 permit 192.168.20.0 255.255.255.0
access-list 10 permit 192.168.30.0 255.255.255.0
access-list 10 permit 192.168.40.0 255.255.255.0
access-list 10 permit 192.168.50.0 255.255.255.0
access-list 10 permit 192.168.60.0 255.255.255.0
access-list 10 permit 192.168.70.0 255.255.255.0
access-list 10 permit 192.168.80.0 255.255.255.0
int range f0/0 - 1
ip nat inside
int s0/1/0
ip nat outside
ip nat inside source list 10 interface s0/1/0 overload