实验八 PPP与广域网链路测试

实验八 PPP与广域网链路测试
一、拓扑图
 
二、实验目标
1 )掌握 PPP 的基本配置,掌握串行链路的调试方法和链路通信质量方法
2 )理解 PPP 的协商过程,掌握 PPP 协议的调试方法。
3 )掌握 PPP 认证的配置方法,理解 PAP CHAP 认证过程,掌握 PPP 认证调试方法。
4 )掌握 PPP Multilink 的配置方法及调试
 
三、实验内容及测试
1)本信息配置
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#line console 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0
Router(config-line)# no login
Router(config-line)#line aux 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0
Router(config-line)# no login
Router(config-line)# privilege level 15
Router(config-line)#line vty 0 4
Router(config-line)# no login
Router(config-line)# privilege level 15
Router(config-line)#exit
Router(config)#no cdp run
Router(config)#no ip http server
 
2RT1进行PPP配置(主认证方)
RT1(config)#interface serial 0/0
RT1(config-if)#encapsulation ppp
RT1(config-if)#ip address 192.168.13.1 255.255.255.252
RT1(config-if)#ppp authentication pap
RT1(config-if)#no shutdown
RT1(config)#username RT3 password tltl
  RT3 进行PPP配置(被认证方)
RT3(config)#interface s0/0
RT3(config-if)#encapsulation ppp
RT3(config-if)#ip address 192.168.13.2 255.255.255.252
RT3(config-if)#no shutdown
RT3(config-if)#ppp pap sent-username RT3 password tltl
RT3(config-if)#
*Mar  1 00:22:44.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
RT3(config-if)#do ping 192.168.13.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/64 ms
3RT1进行有数据库的PPP配置(双方证方)
RT1(config)#username RT3 password 333
RT1(config)#interface s0/0
RT1(config-if)#ip address 192.168.13.1 255.255.255.252
RT1(config-if)#encapsulation ppp
RT1(config-if)#ppp authentication pap
RT1(config-if)#ppp pap sent-username RT1 password 111
    RT3 进行有数据库的PPP配置(双方证方)
RT3(config)#username RT1 password 111
// 数据库中存放 RT1对应密码111的资料
RT3(config)#interface s0/0
RT3(config-if)#ip address 192.168.13.2 255.255.255.252
RT3(config-if)#encapsulation ppp
RT3(config-if)#ppp authentication pap
RT3(config-if)#ppp pap sent-username RT3 password 333
 
4RT1进行CHAP配置(被认证方)
R1(config)#interface s0/0
R1(config-if)#ip address 10.10.13.1 255.255.255.252
R1(config-if)#encapsulation ppp
R1(config-if)#ppp chap password 111
R1(config-if)#no shutdown
RT3 进行CHAP配置(主认证方)
R3(config)#username R1 password 111
R3(config)#interface S0/0
R3(config-if)#ip add 10.10.13.2 255.255.255.252
R3(config-if)#encapsulation ppp
R3(config-if)#ppp authentication chap
R3(config-if)#no shutdown
5RT1进行CHAP配置(双向认证)
R1(config)#username server password 333
R1(config)#interface s0/0
R1(config-if)#ip address 10.10.13.1 255.255.255.252
R1(config-if)#no shutdown
*Mar  1 00:01:59.259: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
R1(config-if)#encapsulation ppp
R1(config-if)#ppp chap hostname client
R1(config-if)#do show ip int  brief      
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.10.13.1      YES manual up                    up     
Serial0/1                  unassigned      YES unset  administratively down down   
Serial0/2                  unassigned      YES unset  administratively down down   
Serial0/3                  unassigned      YES unset  administratively down down 
R1#ping 10.10.13.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/51/84 ms
RT3 进行CHAP配置(双向认证)
R3(config)#username client password 333
R3(config)#interface s0/0
R3(config-if)#ip address 10.10.13.2 255.255.255.252
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#
*Mar  1 00:03:47.835: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
R3(config-if)#
*Mar  1 00:03:48.963: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3(config-if)#ppp authentication chap
 
R3(config)#do show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.10.13.2      YES manual up                    up     
Serial0/1                  unassigned      YES unset  administratively down down   
Serial0/2                  unassigned      YES unset  administratively down down   
Serial0/3                  unassigned      YES unset  administratively down down
R3(config)#do ping 10.10.13.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/44/76 ms
6R1PPP捆绑配置
R1(config)#interface MUltilink 1
*Mar  1 00:02:43.443: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to down
R1(config-if)#ip address 10.10.13.1 255.255.255.252
R1(config-if)#ppp multilink group 1
R1(config-if)#exit
R1(config)#interface serial 0/0
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#exit
R1(config)#interface serial 0/1
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  unassigned      YES manual up                    up     
Serial0/1                  unassigned      YES manual up                    up     
Serial0/2                  unassigned      YES unset  administratively down down   
Serial0/3                  unassigned      YES unset  administratively down down   
Multilink1                 10.10.13.1      YES manual up                    up  
R1#ping 10.10.13.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/49/72 ms
R3 PPP捆绑配置
R3(config)#interface MUltilink 1
*Mar  1 00:02:43.443: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to down
R3(config-if)#ip address 10.10.13.1 255.255.255.252
R3(config-if)#ppp multilink group 1
R3(config-if)#exit
R3(config)#interface serial 0/0
R3(config-if)#no ip address
R3(config-if)#encapsulation ppp
R3(config-if)#ppp multilink group 1
R3(config-if)#exit
R3(config)#interface serial 0/1
R3(config-if)#no ip address
R3(config-if)#encapsulation ppp
R3(config-if)#ppp multilink group 1
    R3#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  unassigned      YES manual up                    up     
Serial0/1                  unassigned      YES manual up                    up     
Serial0/2                  unassigned      YES unset  administratively down down   
Serial0/3                  unassigned      YES unset  administratively down down   
Multilink1                 10.10.13.2      YES manual up                    up
     R3#ping 10.10.13.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/51/96 ms
 
四、遇到的问题及思考
在完成PPP链路捆绑的时候,发现端口协议无法UP,询问后才知道,PPT上的示范并不能通,要将双方启用    CHAP的命令PPP authentication CHAP  no掉,no掉之后发现可以Ping通,之前不通的原因就在于都启用了CHAP认证,于是我又启用了CHAP认证,在双方都添加了一个数据库,实现双向认证,发现可行。
五、实验心得
这次实验涉及的PAPCHAP协议虽然看起来比较容易,但是一旦深究起来,发现并不简单。理论上的东西,经过实验才发现了更多的问题。所以,理论和实验应该相结合,并且,在实验中,要求甚解,要想着去完成实验要求以外的内容,不怕做不到,只怕想不到。
 

本文出自 “IT入门” 博客,谢绝转载!

你可能感兴趣的:(职场,休闲,ppp,广域网,链路测试)