RIP路由协议实验

任务一

RIP路由协议实验_第1张图片

1 R1,R2,R3配置好rip V1 观察不连续子网的产生的后果,

在R2上ping 10.1.1.0/24网段的IP,观察结果如何?

2接下来配置好rip v2 让10.1.1.0/24网段与10.1.2.0/24网段能互相ping通

使用debug ip rip 来观察rip v1和rip v2的更新报文

任务二

clip_image004

1配置A,B,C的rip v2

v 实现10.1.1.2、10.1.2.2和192.168.2.2三台主机能够互相通信(提示:水平分割)

2当全网互通后,在A上使用passive-int 命令,让A不发送路由更新给B,C;

任务三:

自己设计一个拓朴,测试浮动静态路由

image

实验步骤:【必写】

分类写出你的实验进行中的步骤,可用文字或图片加水印标记

1.

任务一思路:

对于路由器:

1:命名

2:设置端口IP

3:设置RIPv1版本

4:设置RIPv2版本

查看命令:

查看基本配置命令:

show running-config

查看路由信息:

show ip route

查看路由协议:

show ip protocol

配置文档:

R1

enable

config terminal

no ip domain-lookup

hostname R1

interface loop 0

ip address 10.1.1.1 255.255.255.0 //设置IP

no shutdown

interface f0/0

ip address 192.168.1.1 255.255.255.0 //设置IP

no shutdown

exit

router rip //设置RIP版本

network 10.1.1.0

network 192.168.1.0

end

write

config terminal

router rip //设置RIPv2版本

network 10.1.1.0

network 192.168.1.0

version 2

no auto-summary

end

write

R2

enable

config terminal

no ip domain-lookup

hostname R2

interface f1/0

ip address 192.168.1.2 255.255.255.0 //设置IP

no shutdown

interface f0/0

ip address 192.168.2.1 255.255.255.0 //设置IP

no shutdown

exit

router rip //设置RIP版本

network 192.168.1.0

network 192.168.2.0

end

write

config terminal

router rip //设置RIPv2版本

network 192.168.2.0

network 192.168.1.0

version 2

no auto-summary

end

write

R3

enable

config terminal

no ip domain-lookup

hostname R3

interface loop 0

ip address 10.1.2.1 255.255.255.0 //设置IP

no shutdown

interface f0/0

ip address 192.168.2.2 255.255.255.0 //设置IP

no shutdown

exit

router rip 、//设置RIP版本

network 10.1.2.0

network 192.168.1.0

end

write

config terminal

router rip //设置RIPv2版本

network 10.1.2.0

network 192.168.2.0

version 2

no auto-summary

end

write

调试截图 :

clip_image002[4]

clip_image004[4]clip_image006clip_image008clip_image010clip_image012clip_image014clip_image016

2:

思路:

1:对于路由器:

1:命名

2:设置端口IP

3:设置RIPv2版本

对于PC:

1:命名

2:禁用路由功能

3:设置ip

查看命令:

查看基本配置:

show running-config

查看版本信息:

show ip route

查看路由协议信息:

show ip protocol

R1

enable

config terminal

no ip domain-lookup

hostname R1

interface f0/0

ip address 10.1.1.1 255.255.255.0 //设置IP

no shutdown

interface f1/0

ip address 192.168.1.1 255.255.255.0 //设置IP

no shutdown

exit

router rip //设置RIP版本

network 10.1.1.0

network 192.168.1.0

version 2

no auto-summary

end

write

R2

enable

config terminal

no ip domain-lookup

hostname R2

interface f0/0

ip address 10.1.2.1 255.255.255.0 //设置IP

no shutdown

interface f1/0

ip address 192.168.1.2 255.255.255.0 //设置IP

no shutdown

exit

router rip //设置RIP版本

network 10.1.2.0

network 192.168.1.0

version 2

no auto-summary

end

write

R3

enable

config terminal

no ip domain-lookup

hostname R3

interface f0/0

ip address 192.168.1.3 255.255.255.0 //设置IP

no shutdown

interface f1/0

ip address 192.168.2.1 255.255.255.0 //设置IP

no shutdown

exit

router rip //设置RIP版本

network 192.168.1.0

network 192.168.2.0

version 2

no auto-summary

end

write

PC1:

enable

config terminal

no ip routing

hostname pc1

interface f0/0

ip address 10.1.1.2 255.255.255.0 //设置IP

no shutdown

end

write

PC2:

enable

config terminal

no ip routing

hostname pc2

interface f0/0

ip address 10.1.2.2 255.255.255.0 //设置IP

no shutdown

end

write

PC3:

enable

config terminal

no ip routing

hostname pc3

interface f0/0

ip address 192.168.2.2 255.255.255.0 //设置IP

no shutdown

end

write

测试截图:

clip_image018

3:

对于路由器:

1:命名

2:设置端口IP

3:设置静态路由

查看命令:

查看基本配置命令:

show running-config

查看路由信息:

show ip route

查看路由协议:

show ip protocol

---------------------------------------

配置文档:

R1

enable

config terminal

no ip domain-lookup

hostname R1

interface loop 0

ip address 10.1.1.1 255.255.255.0 //设置IP

no shutdown

interface f0/0

ip address 192.168.1.1 255.255.255.0 //设置IP

no shutdown

exit

ip route 10.1.2.0 255.255.255.0 192.168.1.2 //设置静态路由

ip route 192.168.2.0 255.255.255.0 192.168.1.2

end

write

R2

enable

config terminal

no ip domain-lookup

hostname R2

interface f1/0

ip address 192.168.1.2 255.255.255.0 //设置IP

no shutdown

interface f0/0

ip address 192.168.2.1 255.255.255.0 //设置IP

no shutdown

exit

ip route 10.1.1.0 255.255.255.0 192.168.1.1 //设置静态路由

ip route 10.1.2.0 255.255.255.0 192.168.2.2

end

write

R3

enable

config terminal

no ip domain-lookup

hostname R3

interface loop 0

ip address 10.1.2.1 255.255.255.0 //设置IP

no shutdown

interface f0/0

ip address 192.168.2.2 255.255.255.0 //设置IP

no shutdown

exit

ip route 10.1.1.0 255.255.255.0 192.168.2.1 //设置静态路由

ip route 192.168.1.0 255.255.255.0 192.168.2.1

end

write

测试截图:

clip_image020clip_image022

实验结论及排除思路或命令:【必写】

1. 写出通过本次上机实验操作,你得出了什么样的结论

任务一:动态路由宣告的是网络段,就是v1、v2版本在调试的时候一个是携带子网掩码,另外一个是不携带子网掩码,造成的问题是,如果都是同一个网段,比方说上面第一个实例,如果是10.1.1.0/24,和10.1.2.0/24这2个网段的话,v1版本会让这2个网段归属到10.0.0.0/8这个网络段去。。。 这个就是V1版本的问题。。。导致2个网段不能连通。

任务二:

这里3路由是通过交换机来连接的,

交换机的接口不需要开通,只要连接了就能够

自动开通。。。。而路由器必须设置成no shutdown,。

任务三:

浮动路由的原理,就是把一个网段断开,看其它路由器工作原理,

并查看路由器信息(show ip route),就会出现浮动。

你可能感兴趣的:(协议,路由,休闲,实验,rip)