frame-relay(使用RIP协议)
(注:本实例使用的模拟软件是BOSON5.31)
Router1:
Router>en
Router#c onfig t
Router#host R1
% Invalid input detected at '^' marker.
Router#c onfig t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host R1
R1(config)#int eth 0
R1(config-if)#ip add 172.16.1.1 255.255.255.0
R1(config-if)#no shut
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
R1(config-if)#int se 0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shut
%LINK-3-UPDOWN: Interface Serial0, changed state to up
%LINK-3-UPDOWN: Interface Serial0, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1(config-if)#int se0.0 multipoint
R1(config-subif)#ip add 11.1.1 .1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 102
R1(config-subif)#frame-relay interface-dlci 103
R1(config-subif)#exit
%LINK-3-UPDOWN: Interface Serial0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
21:49:39: %FR-5-DLCICHANGE: Interface Serial0.0 - DLCI 103 state changed to ACTIVE
R1(config)#router rip
R1(config-router)#network 172.16.1.0
R1(config-router)#network 11.1.1 .0
R1(config-router)#version 2
R1(config-router)#exit
R1(config)#exit
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF , IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route
Gateway of last resort is not set
C 172.16.1.0/24 is directly connected, Ethernet0
C 11.1.1 .0/24 is directly connected, 11.1.1.1
R 172.16.2.0/24 [120/1] vi a 11.1.1 .2, 00:07:27, Serial0.0
R 172.16.3.0/24 [120/1] vi a 11.1.1 .3, 00:06:30, Serial0.0
R1#ping 11.1.1 .2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1 .2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#ping 11.1.1 .3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1 .3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#show fr map
Serial0.0 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast
status defined, active
(up): point-to-point dlci, dlci 103(0x66,0x1860), broadcast
status defined, active
Router2:
Router#c onfig t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host R2
R2(config)#int eth 0
R2(config-if)#ip add 172.16.2.1 255.255.255.0
R2(config-if)#no shut
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
R2(config-if)#int se0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shut
%LINK-3-UPDOWN: Interface Serial0, changed state to up
R2(config-if)#int se0.0 multipoint
R2(config-subif)#ip add 11.1.1 .2 255.255.255.0
R2(config-subif)#frame-relay interface-dlci 201
R2(config-subif)#frame-relay interface-dlci 203
21:49:39: %FR-5-DLCICHANGE: Interface Serial0.0 - DLCI 203 state changed to ACTIVE
R2(config-subif)#exit
R2(config)#router rip
R2(config-router)#network 172.16.2.0
R2(config-router)#network 11.1.1 .0
R2(config-router)#version 2
R2(config-router)#exit
R2(config)#exit
R2#ping 11.1.1 .1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1 .1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#ping 11.1.1 .3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1 .3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Router3:
Router#c onfig
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host R3
R3(config)#int eth 0
R3(config-if)#ip add 172.16.3.1 255.255.255.0
R3(config-if)#no shut
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
R3(config-if)#int se0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shut
%LINK-3-UPDOWN: Interface Serial0, changed state to up
R3(config-if)#int se0.0 multipoint
R3(config-subif)#ip add 11.1.1 .3 255.255.255.0
R3(config-subif)#frame-relay interface-dlci 301
R3(config-subif)#frame-relay interface-dlci 302
21:49:39: %FR-5-DLCICHANGE: Interface Serial0.0 - DLCI 302 state changed to ACTIVE
R3(config-subif)#exit
R3(config)#router rip
R3(config-router)#network 172.16.3.0
R3(config-router)#network 11.1.1 .0
R3(config-router)#version 2
R3(config-router)#
R3(config-router)#exit
R3(config)#exit
R3#ping 11.1.1 .1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1 .1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R3#ping 11.1.1 .2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1 .2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms