|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface range
{
port-range
}
|
进入组配置状态
|
Step 3
|
|
可以使用平时的端口配置命令进行配置
|
Step 4
|
end
|
退回
|
Step 5
|
show interfaces
[
interface-id
]
|
验证配置
|
Step 6
|
copy running-config startup-config
|
保存
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
.
|
Step 2
|
interface
interface-id
|
进入端口配置状态
.
|
Step 3
|
speed
{
10 | 100 | 1000 | auto | nonegotiate
}
|
设置端口速率
注
1000
只工作在千兆口
. GBIC
模块只工作在
1000 Mbps
下
.
nonegotiate
只能在这些GBIC上用
1000BASE-SX, -LX, and -ZX GBIC.
|
Step 4
|
duplex
{
auto | full | half
}
|
设置全双工或半双工
.
|
Step 5
|
end
|
退出
|
Step 6
|
show interfaces
interface-id
|
显示有关配置情况
|
Step 7
|
copy running-config startup-config
|
保存
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置模式
|
Step 2
|
interface
interface-id
|
进入要加入描述的端口
|
Step 3
|
description
string
|
加入描述
(
最多
240
个字符
).
|
Step 4
|
end
|
退回
.
|
Step 5
|
show interfaces
interface-id
description
or
show running-config
|
验证
.
|
Step 6
|
copy running-config startup-config
|
保存
|
|
Show Commands for Interfaces
Command
|
目的
|
show interfaces
[
interface-id
]
|
显示所有端口或某一端口的状态和配置
.
|
show interfaces
interface-id
status
[
err-disabled
]
|
显示一系列端口的状态或错误-关闭的状态
|
show interfaces
[
interface-id
]
switchport
|
显示二层端口的状态,可以用来决定此口是否为二层或三层口。
|
show interfaces
[
interface-id
]
description
|
显示端口描述
|
show running-config interface
[
interface-id
]
|
显示当前配置中的端口配置情况
|
show version
|
显示软硬件等情况
|
|
Clear
命令
|
目的
|
clear counters
[
interface-id
]
|
清除端口计数器
.
|
clear line
[
number |
console 0
|
vty
number
]
|
重置异步串口的硬件逻辑
|
|
Note
clear counters
命令只清除用show interface所显示的计数,不影响用snmp得到的计数
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
{vlan
vlan-id
} | {{
fastethernet
|
gigabitethernet
}
interface-id
} | {
port-channel
port-channel-number
}
|
选择要关闭的端口
|
Step 3
|
shutdown
|
关闭
|
Step 4
|
end
|
退出
|
Step 5
|
show running-config
|
验证
|
|
|
注意
不要手工删除
vlan.dat
文件,可能造成VLAN的不完整。 如要删除vlan需要用有关的命令来进行
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
vlan
vlan-id
|
输入一个
VLAN
号
,
然后进入vlan配置状态,可以输入一个新的VLAN号或旧的来进行修改。
|
Step 3
|
name
vlan-name
|
(
可选)输入一个VLAN名,如果没有配置VLAN名,缺省的名字是VLAN号前面用0填满的4位数,如
VLAN0004
是VLAN4的缺省名字
|
Step 4
|
mtu
mtu-size
|
(
可选
)
改变MTU大小
|
Step 5
|
end
|
退出
|
Step 6
|
show vlan
{
name
vlan-name |
id
vlan-id
}
|
验证
|
Step 7
|
copy running-config startup config
|
(
可选
)
保存配置
|
|
命令
|
目的
|
Step 1
|
vlan database
|
进入VLAN配置状态
|
Step 2
|
vlan
vlan-id
name
vlan-name
|
加入VLAN号及VLAN名
|
Step 3
|
vlan
vlan-id
mtu
mtu-size
|
(
可选
)
修改MTU大小
|
Step 4
|
exit
|
更新
VLAN
数据�觳⑼顺�
|
Step 5
|
show vlan
{
name
vlan-name |
id
vlan-id
}
|
验证配置
|
Step 6
|
copy running-config startup config
|
保存配置(可选)
|
|
|
注意
当删除一个VLAN时,原来属于此VLAN的端口将处于非激活的状态,直到将其分配给某一VLAN。
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
no vlan
vlan-id
|
删除某一VLAN
.
|
Step 3
|
end
|
退出
|
Step 4
|
show vlan brief
|
验证
|
Step 5
|
copy running-config startup config
|
保存
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入要分配的端口
|
Step 3
|
switchport mode access
|
定义二层口
|
Step 4
|
switchport access vlan
vlan-id
|
把端口分配给某一VLAN
|
Step 5
|
end
|
退出
|
Step 6
|
show running-config interface
interface-id
|
验证端口的VLAN号
|
Step 7
|
show interfaces
interface-id
switchport
|
验证端口的管理模式和VLAN情况
|
Step 8
|
copy running-config startup-config
|
保存配置
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入端口配置状态
|
Step 3
|
switchport mode
{
dynamic
{
auto
|
desirable
} |
trunk
}
|
配置二层trunk模式。
dynamic auto
―
自动协商是否成为trunk
dynamic desirable
―
把端口设置为trunk如果对方端口是
trunk, desirable,
或自动模式
trunk
―
设置端口为强制的trunk方式,而不理会对方端口是否为trunk
|
Step 4
|
switchport access vlan
vlan-id
|
(
可选
)
指定一个缺省
VLAN,
如果此端口不再是trunk
|
Step 5
|
switchport trunk native vlan
vlan-id
|
指定
802.1Q native VLAN
号
|
Step 6
|
end
|
退出
|
Step 7
|
show interfaces
interface-id
switchport
|
显示有关
switchport
的配置
|
Step 8
|
show interfaces
interface-id
trunk
|
显示有关trunk的配置
|
Step
9
|
copy running-config startup-config
|
保存配置
|
|
Command
|
Purpose
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入端口配置
|
Step 3
|
switchport mode trunk
|
配置二层口为trunk
|
Step 4
|
switchport trunk allowed vlan
{
add
|
all
|
except
|
remove
}
vlan-list
|
(
可选
)
配置
trunk
允许的VLAN
.
使用
add
,
all
,
except
,
remove
关健字
|
Step 5
|
end
|
退出
|
Step 6
|
show interfaces
interface-id
switchport
|
验证VLAN配置情况
.
|
Step 7
|
copy running-config startup-config
|
保存配置
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入配置成802.1qtrunk的端口
|
Step 3
|
switchport trunk native vlan
vlan-id
|
配置native VLAN号
|
Step 4
|
end
|
退出
|
Step 5
|
show interfaces
interface-id
switchport
|
验证native VLAN配置
|
Step 6
|
copy running-config startup-config
|
保存配置
|
|
|
Command
|
Purpose
|
Step 1
|
configure terminal
|
进入
Switch
1
配置状态
|
Step 2
|
vtp domain
domain-name
|
配置VTP域
|
Step 3
|
vtp server
|
将
Switch 1
配置成
VTP server.
|
Step 4
|
end
|
退出
|
Step 5
|
show vtp status
|
验证VTP的配置
|
Step 6
|
show vlan
|
验证VLAN
|
Step 7
|
configure terminal
|
进入配置状态
|
Step 8
|
interface
fastethernet 0/1
|
进入F0/1端口
|
Step
9
|
switchport mode trunk
|
配置成trunk端口
|
Step 1
0
|
end
|
退出
|
Step 11
|
show interfaces
fastethernet0/1
switchport
|
验证VLAN配置
|
Step 1
2
|
|
在switch1上的F0/2上重复7到11步骤
|
Step 1
3
|
|
在
Switch 2
的F0/1,F0/2上重复7到11步骤。
|
Step
14
|
show vlan
|
当trunk已经起来,在switch2上验证已经学到相关的vlan配置
|
Step 15
|
configure terminal
|
在
Switch 1
上进入配置状态
|
Step 16
|
interface fastethernet0/1
|
进入要配置的端口
|
Step 17
|
spanning-tree vlan 8 port-priority 10
|
将端口权值10赋与
VLAN 8.
|
Step 18
|
spanning-tree vlan 9 port-priority 10
|
将端口权值10赋与
VLAN
9
.
|
Step 19
|
spanning-tree vlan 10 port-priority 10
|
将端口权值10赋与
VLAN
10
.
|
Step 20
|
exit
|
退回
.
|
Step 2
1
|
interface fastethernet0/2
|
进入F0/2
|
Step 2
2
|
spanning-tree vlan 3 port-priority 10
|
将端口权值10赋与
VLAN
3
.
|
Step 2
3
|
spanning-tree vlan 4 port-priority 10
|
将端口权值10赋与
VLAN
4
.
|
Step 2
4
|
spanning-tree vlan 5 port-priority 10
|
将端口权值10赋与
VLAN
5
.
|
Step 2
5
|
spanning-tree vlan 6 port-priority 10
|
将端口权值10赋与
VLAN
10
.
|
Step 2
6
|
end
|
退出
|
Step 2
7
|
show running-config
|
验证配置
|
Step 2
8
|
copy running-config startup-config
|
保存配置
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入
Switch
1
配置状态
|
Step 2
|
interfa
c
e fastethernet 0/1
|
进入F0/1
|
Step
3
|
switchport mode trunk
|
配置Trunk,只能是dot1q模式
|
Step
4
|
exit
|
退回
|
Step
5
|
|
在F0/2口上重复2-4步骤
|
Step 6
|
end
|
退出
|
Step 7
|
show running-config
|
验证配置
|
Step 8
|
show vlan
|
验证switch1已经学到Vlan
|
Step 9
|
configure terminal
|
进入配置状态
|
Step 10
|
interface fastethernet 0/1
|
进入F0/1
|
Step 11
|
spanning-tree vlan 2 cost 30
|
设置Vlan2生成树路径值为30
|
Step 12
|
spanning-tree vlan 3 cost 30
|
设置Vlan3生成树路径值为30
|
Step 13
|
spanning-tree vlan 4 cost 30
|
设置Vlan4生成树路径值为30
|
Step 14
|
end
|
退出
|
Step 15
|
|
在switch1的F0/2上重复9-11步骤设置VLAN8,9,10生成树路径值为30
|
Step 16
|
exit
|
退出
|
Step 17
|
show running-config
|
验证配置
|
Step 18
|
copy running-config startup-config
|
保存配置
|