【POJ 1330】 Nearest Common Ancestors(LCA)

【POJ 1330】 Nearest Common Ancestors(LCA)


Nearest Common Ancestors
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22677   Accepted: 11836

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

【POJ 1330】 Nearest Common Ancestors(LCA)_第1张图片 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

Source

Taejon 2002

拖了这么久的LCA总算是学会了。。一种做法= =

dfs+RMQ

http://dongxicheng.org/structure/lca-rmq/

这篇文章+对着模板看 学会的。。


代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>

using namespace std;
const int msz = 1e4;

struct Edge
{
    int v,next;
};

Edge eg[msz];
int head[msz+1];//建树

bool vis[msz+1];//搜树根

int P[msz+1],F[msz*2];//存每个结点第一次出现的位置和遍历经过的结点次序
int rmq[msz+1];//开成rmq 其实是每个结点的深度 配合dp动归出每个区间各自深度最小的结点
int dp[msz*2][15];//配合rmq 存储区间深度最小点
int n,cnt;

void dfs(int pos, int dep)//搜一下 把遍历次序 每个结点第一次出现位置 结点深度存下来 
{
    //printf("%d %d %d\n",pos,dep,cnt);
    rmq[pos] = dep;
    P[pos] = cnt;
    F[cnt++] = pos;

    for(int i = head[pos]; i != -1; i = eg[i].next)
    {
        dfs(eg[i].v,dep+1);
        F[cnt++] = pos;
    }
}

void LCA_init(int root)
{
    cnt = 1;
    dfs(root,0);
    
    for(int i = 1; i < n*2; ++i)//初始化rmq
        dp[i][0] = F[i];

    for(int i = 1; (1<<i) < n*2; ++i)//动归
        for(int j = 1; j+(1<<i)-1 < n*2; ++j)
            dp[j][i] = rmq[dp[j][i-1]] < rmq[dp[j+(1<<(i-1))][i-1]]? dp[j][i-1]: dp[j+(1<<(i-1))][i-1];
}

int Search(int u,int v)
{
    if(u > v) swap(u,v);
    int k = log(1.0*(v-u+1))/log(2.0);
    return rmq[dp[u][k]] < rmq[dp[v-(1<<k)+1][k]]? dp[u][k]: dp[v-(1<<k)+1][k];
}

int main()
{
    int t,u,v,root;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n-1; ++i)
        {
            scanf("%d %d",&u,&v);
            eg[i].v = v;
            eg[i].next = head[u];
            head[u] = i;
            vis[v] = 1;
        }

        for(int i = 1; i <= n; ++i)
        {
            if(vis[i]) continue;
            root = i;
            break;
        }

        LCA_init(root);
        scanf("%d %d",&u,&v);
        printf("%d\n",Search(P[u],P[v]));
    }
    return 0;
}




你可能感兴趣的:(【POJ 1330】 Nearest Common Ancestors(LCA))