5-38 寻找大富翁 (25分)

5-38 寻找大富翁   (25分)

2015年胡润研究院的调查显示,截至2014年9月,个人资产在600万元以上高净值人群达290万人。假设给出N个人的个人资产值,请快速找出资产排前M位的大富翁。

输入格式:

输入首先给出两个正整数N106)和M10),其中N为总人数,M为需要找出的大富翁数;接下来一行给出N个人的个人资产值,以百万元为单位,为不超过长整型范围的整数。数字间以空格分隔。

输出格式:

在一行内按非递增顺序输出资产排前M位的大富翁的个人资产值。数字间以空格分隔,但结尾不得有多余空格。

输入样例:

8 3
8 12 7 3 20 9 5 18

输出样例:

20 18 12
 
  • 时间限制:500ms
  • 内存限制:64MB
  • 代码长度限制:16kB
  • 判题程序:系统默认
  • 作者:陈越
  • 单位:浙江大学

http://pta.patest.cn/pta/test/15/exam/4/question/865

#include <cstdio>  
#include <sstream>  
#include <cstring>  
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <queue>

using namespace std;

int n , m  ;

struct cmp
{
	bool operator()(long int x , long int y)
	{
		return x < y ;
	}
};

priority_queue<long int ,vector<long int> , cmp> pq ;

int main()
{
    // freopen("in.txt", "r", stdin);
	scanf("%d%d" ,&n , &m) ;
	int tmp ;
	while(n--)
	{
		scanf("%d" , &tmp) ;
		pq.push(tmp) ;
	}
	while(m)
	{
		tmp = pq.top() ;
		pq.pop() ;
		m -- ;
		if(m == 0)
			printf("%d\n" , tmp );
		else
			printf("%d " , tmp );
	}
	return 0 ;
}

你可能感兴趣的:(5-38 寻找大富翁 (25分))