HDU 1018.Big Number【7月25】

Big Number

这道题,没有什么难点什么的,就是为了涨姿势。
Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
   
   
   
   
2 10 20
 

Sample Output
   
   
   
   
7 19

这是一道比较有意思的题目。给出一个数,然后求出这个数的阶乘的位数。第一想法肯定就是先求出这个数的阶乘,然后数有几位数。然并卵!肯定求不出的。然后找到如下资料:N的阶乖的位数等于LOG10(N!)=LOG10(1)+.....LOG10(N)。ok,上代码:

#include<cstdio>
#include<cmath>
int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        int x;
        double sum=0;
        scanf("%d",&x);
        for(int j=1;j<=x;j++)
            sum+=log10(j);
        printf("%d\n",int(sum)+1);
    }
    return 0;
}
同时又找到一点资料:Stirling公式:n!与√(2πn) * n^n * e^(-n)的值十分接近
故log10(n!) = log(n!) / log(10) = ( n*log(n) - n + 0.5*log(2*π*n))/log(n);
下面是别人的代码:

#include <stdio.h>
#include <math.h>

const double PI = acos(-1.0);
const double ln_10 = log(10.0);

double reback(int N)
{
    return ceil((N*log(double(N))-N+0.5*log(2.0*N*PI))/ln_10);
}    

int main()
{
	int cas,n;
	scanf("%d",&cas);
	while(cas--)
	{
		scanf("%d",&n);
		if(n<=1)printf("1\n");
		else printf("%.0lf\n",reback(n));
	}
	return 0;
}

真的涨姿势!

你可能感兴趣的:(number,HDU,big,1018,log10N)