hdu oj 1907 john

hdu oj 1907 john

题目:

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3618    Accepted Submission(s): 2059


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
    
    
    
    
2 3 3 5 1 1 1
 

Sample Output
    
    
    
    
John Brother
 

题意:

  •  尼姆博弈题。 尼姆博弈详细教程点此。
  •  经典的尼姆问题是谁哪拿到最后一个则谁赢,本题是拿最后一个的输。
  • 对于N堆的糖,一种情况下是每堆都是1,那么谁输谁赢看堆数就知道;
  • 对于不都是1的话,则判断初始局势是否为奇异局势。

代码:

#include<stdio.h>
#include<stdlib.h>
int main()
{
    int n,m,v,ans,flag,i;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        ans=0;flag=0;
        for(i=0;i<m;i++)
        {
            scanf("%d",&v);
            ans=ans^v;
            if(v>1)
                flag=1;
        }
        if(flag==0)
        {
            if(m%2==0)
                printf("John\n");
            else
                printf("Brother\n");
        }
        else
        {
            if(ans==0)
                printf("Brother\n");
            else
                printf("John\n");
        }
    }
    return 0;
}



你可能感兴趣的:(数据结构,算法,博弈)