HDOJ 5137 How Many Maos Does the Guanxi Worth(最短路删点)

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1031    Accepted Submission(s): 353


Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 

Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 

Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 

Sample Input
   
   
   
   
4 5 1 2 3 1 3 7 1 4 50 2 3 4 3 4 2 3 2 1 2 30 2 3 10 0 0
 

Sample Output
   
   
   
   
50 Inf
 
 
题意:刘老板要利用自己的关系找到校长,让孩子进好学校。每一层找关系都要花刘老板的钱。现在你可以删除刘老板关系网除了刘老板和校长的任意一人(1表示刘老板,n表示校长),使得刘老板无法找到校长。若无法阻止刘老板找到校长,则必须使得刘老板的花费最大。
 
题目解析:刘老板找到校长,肯定要使得自己的花费最少,即此题时最短路问题。按照题意就是在图中删去一点,使得起点到终点不能连通,若删除任意一点,起点到终点任连通,则就寻找在删除任意一点的情况下使得最短路径的值最大。
 
注意:图中删去一点等于删去与此点相连的所有边。(经行下个点删除前,要还原上一个点)
 
 
dijkstra算法,具体代码如下:
 
 
#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
#define maxn 35
#define maxm 1010
int map[maxn][maxn],dis[maxn],n;
int s[maxm],e[maxm],d[maxm];

void dijkstar()
{
	int i,j,min,next=1;
	int visit[maxn];
	for(i=1;i<=n;++i)
	{
		dis[i]=map[1][i];
		visit[i]=0;
	}
	visit[1]=1;
	for(i=2;i<=n;++i)
	{
		min=INF;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&min>dis[j])
			{
				next=j;
				min=dis[j];
			}
		}
		visit[next]=1;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&dis[j]>dis[next]+map[next][j])
			   dis[j]=dis[next]+map[next][j];
		}
	}
}

int main()
{
	int m,i,j,a,b,c;
	while(scanf("%d%d",&n,&m)&&n||m)
	{
		for(i=1;i<=n;++i)
		{
			d[i]=INF;//初始化储存权值的零时数组 
			for(j=1;j<=n;++j)
			{
				if(i==j)
				  map[i][j]=0;
				else
				   map[i][j]=INF;
			}
		}
		for(i=0;i<m;++i)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
			   map[a][b]=map[b][a]=c;
		}
		int sign=0;
		int ans=-1;
	    for(i=2;i<n;++i)//从2到n-1,分别删去每个点 
	    {
	    	for(j=1;j<=n;++j)//遍历当前点与那些点相连 
	    	{
	    		if(map[i][j]!=INF&&i!=j)
	    		{
	    			d[j]=map[i][j];//记录要删去的边的权值 
	    			map[i][j]=map[j][i]=INF;//删去当前点的边 
	    		}
	    	}
	    	dijkstar();
	    	if(dis[n]==INF)//判断删除当前点后是否连通 
	    	{
	    		sign=1;
	    		break;
	    	}
	    	if(dis[n]>ans)//若连通记录下最大的最短路径权值 
	    	   ans=dis[n];
	    	for(j=1;j<=n;++j)//遍历当前点与那些点相连 
	    	{
	    		if(d[j]!=INF)
	    		{
	    			map[i][j]=map[j][i]=d[j];//还原当前点的边的权值 
	    			d[j]=INF;//清空记录的权值 
	    		}
	    	}
	    }
	    if(sign)
	       printf("Inf\n");
	    else
	       printf("%d\n",ans);
	}
	return 0;
}

你可能感兴趣的:(HDOJ 5137 How Many Maos Does the Guanxi Worth(最短路删点))