HDU 1034.Candy Sharing Game【又是模拟】【8月22】

Candy Sharing Game

Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
   
   
   
   
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
   
   
   
   
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
n个人每个人都有糖果,如果n个人的糖果不想等,上一个人就把自己糖果的一半给下一个人(下一个人把自己的一般给下下一个人之后才能拿上一个人给的一半),这个时候如果自己的糖果是奇数,就从老师那里获得一颗。直到都相等,输出进行了多少轮,并输出每个人的糖果数(一定会达到每个人糖果数都相等)。模拟,代码如下:

#include<cstdio>
int n,f[1010];
bool haha(){//检测是否都相等
    for(int i=0;i<n;i++)
    if(f[i]!=f[(i+1)%n]) return false;
    return true;
}
int main(){
    while(scanf("%d",&n)==1&&n){
        int sum=0,fl;
        for(int i=0;i<n;i++)
            scanf("%d",&f[i]);
        while(!haha()){
            sum++;
            fl=f[n-1]/2;//第一个人要用到
            for(int i=n-1;i>0;i--){//倒着
                f[i]=f[i]/2+f[i-1]/2;
                if(f[i]%2) f[i]++;
            }
            f[0]=f[0]/2+fl;
            if(f[0]%2) f[0]++;//奇数+1
        }
        printf("%d %d\n",sum,f[0]);
    }
    return 0;
}


你可能感兴趣的:(C++,模拟,ACM,HDU,1034)