Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 65180 Accepted Submission(s): 24152
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
好吧,好久没做题了,
从昨天中午到今天一直纠结着一道水题,
让我一度认为自己假期过糊涂了(就3天假),
唉,没想到啊,
每次都把
Runtime Error
(ACCESS_VIOLATION)
看成
Time Limit Exceeded
逼着我把我的一遍一遍的精简下来,
终于,在百度的帮助下看到一个孩子把数组大小从1000改为1001就AC
我也试了一下,果然。。
#include <iostream>
#include <string>
#include <cstring>
using namespace std;
int main(){
string str;
string bln[1001];
int blon[1001]={0};
int i,j,k,max,ma,l,n;
while(cin>>n&&n!=0)
{
j=0; //相当于有几种颜色气球
for(i=0;i<n;++i)
{
cin>>str;
if(0==i)
{
bln[0]=str;
++j;
ma=0; //ma 记录最多气球数的位置
max=0;
continue;
}
for(k=0;k<j;++k)
{
l=0; //l判断气球颜色数是否要加1
if(str==bln[k])
{
++blon[k];
if(blon[k]>max)
{
max=blon[k];
ma=k;
}
l=1;
break;
}
}
if(0==l)
{
bln[j]=str;
++j;
continue;
}
}
cout<<bln[ma]<<endl;
}
return 0;
}