poj 3628 Bookshelf 2(01背包入门或者dfs)

Bookshelf 2
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4064   Accepted: 1857

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where Sis the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

Source

USACO 2007 December Bronze
题目: http://poj.org/problem?id=3628
分析:这题用01背包来解,实在是很牵强,貌似dfs就行了,不过DP的代码还是很短的
同样设f[i]表示i高度能否达到,f[i]=1(f[j]==1,j+h[k]=i),这类背包属于第二类,就是严格限制背包容量,要装满,赋初值时只有f[0]为可达,其他全部不可达,转移时还要判断f[j]是否可达。。。。
代码:
#include<cstdio>
using namespace std;
const int mm=20000000;
bool f[mm];
int h[22];
int i,j,k,n,b,m;
int main()
{
    while(scanf("%d%d",&n,&b)!=-1)
    {
        for(m=i=0;i<n;++i)scanf("%d",&h[i]),m+=h[i];
        for(i=0;i<=m;++i)f[i]=0;
        f[0]=1;
        for(i=0;i<n;++i)
            for(j=m-h[i];j>=0;--j)
                if(f[j])f[j+h[i]]=1;
        for(i=b;i<=m;++i)
            if(f[i])break;
        printf("%d\n",i-b);
    }
    return 0;
}


你可能感兴趣的:(Integer,less,input,each,library,output)