AreYouBusy
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 636 Accepted Submission(s): 269
Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1
3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1
1 1
1 0
2 1
5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10
Sample Output
Author
hphp
Source
2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU
Recommend
zhouzeyong
题目: http://acm.hdu.edu.cn/showproblem.php?pid=3535
分析:这题可以算是比较经典的几种分组背包的融合吧,做完这题,分组背包的基本类型大概也都会了,这次还是比较爽的1A的,尽管由于变量敲错找了好久才过样例= =
共三种类型,至少取一个,最多取一个,随便取,其实都只是循环顺序和更新值时做一些改变就行
代码:
import java.util.*;
public class Main
{
public static void main(String arg[])
{
Scanner cin=new Scanner(System.in);
int oo=-1000000000;
int mn=111;
int m[]=new int[mn],s[]=new int[mn];
int c[][]=new int[mn][mn],w[][]=new int[mn][mn];
int f[]=new int[mn],g[]=new int[mn];
int i,j,k,n,t,tmp;
while(cin.hasNextInt())
{
n=cin.nextInt();
t=cin.nextInt();
for(i=0;i<n;++i)
{
m[i]=cin.nextInt();
s[i]=cin.nextInt();
for(j=0;j<m[i];++j)
{
c[i][j]=cin.nextInt();
w[i][j]=cin.nextInt();
}
}
for(i=0;i<=t;++i)f[i]=g[i]=oo;
f[0]=g[0]=0;
for(i=0;i<n;++i)
if(s[i]==1)
{
for(k=t;k>=0;f[k--]=tmp)
for(j=0,tmp=f[k];j<m[i];++j)
if(k>=c[i][j])
tmp=Math.max(tmp,f[k-c[i][j]]+w[i][j]);
}
else if(s[i]==2)
{
for(j=0;j<m[i];++j)
for(k=t;k>=c[i][j];--k)
f[k]=Math.max(f[k],f[k-c[i][j]]+w[i][j]);
}
for(i=0;i<n;++i)
if(s[i]==0)
{
for(j=0;j<=t;f[j++]=oo)g[j]=f[j];
for(j=0;j<m[i];++j)
for(k=t;k>=c[i][j];--k)
{
f[k]=Math.max(f[k],g[k-c[i][j]]+w[i][j]);
g[k]=Math.max(g[k],g[k-c[i][j]]+w[i][j]);
}
}
for(i=1;i<t;++i)f[t]=Math.max(f[t],f[i]);
f[t]=Math.max(f[t],-1);
System.out.println(f[t]);
}
}
}