poj-1753Flip Game【DFS】【枚举】

Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 37012   Accepted: 16101

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

poj-1753Flip Game【DFS】【枚举】_第1张图片Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

Northeastern Europe 2000


题意:

翻转游戏,对网格中任何一个棋子进行翻转,则它的上下左右的棋子都要翻转,其实我们会发现,翻一次变化一次,翻两次等于没翻。所以在4*4的网格中最多有16步操作。

思路:

DFS进行枚举判断。


ACcode:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
bool map[6][6];
bool flag;
int step;
int dr[] = {-1, 0, 0, 0, 1};
int dc[] = {0, -1, 0, 1, 0};
bool isall() // 判断 是否清一色 
{
	for(int i = 1; i < 5; i++)
		for(int j = 1; j < 5; j++ )
			if(map[i][j]!=map[1][1])
				return 0;
	return 1;			
}
void flip(int row, int col) // 对某个点进行反转则它上下左右四个都要变 
{
	int i, j, r, c;
	for( i = 0; i < 5; i++)
	{
		r = row+dr[i];
		c = col+dc[i];
		map[r][c] = !map[r][c];
	}
}
void dfs(int row, int col, int num)	//点(row,col)为现在是否要操作的点
{
	if(num == step){
		flag = isall();
		return;
	}
	if(flag || row==5)	return;	
	flip(row, col);		//要对点(row,col)进行翻动
	if(col < 4)	
		dfs(row, col+1, num+1);
	else
		dfs(row+1, 1, num+1);	
	flip(row, col);		//还原状态,不对点(row,col)进行翻动,翻两次等于没翻~ 
	if(col < 4)
		dfs(row, col+1, num);
	else
		dfs(row+1, 1, num);			
}
int main(){
	char c;
	for(int i = 1; i <= 4; i++)
	{
		for(int j = 1; j <= 4; j++)
		{
			scanf("%c", &c);
			if(c == 'b')
			map[i][j] = true;
			
		}
		getchar();
	}
	for(step = 0; step <= 16; step++)	// 枚举 0 ~ 16 步 
	{
		dfs(1, 1, 0);
		if(flag)	break;
	}
	if(flag)
		printf("%d\n", step);
	else
		printf("Impossible");	
	return 0;
} 


你可能感兴趣的:(poj-1753Flip Game【DFS】【枚举】)