HDU 5444.Elven Postman【2015 ACM/ICPC Asia Regional Changchun Online】【二叉树建立与遍历】9月14

Elven Postman

Problem Description
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

HDU 5444.Elven Postman【2015 ACM/ICPC Asia Regional Changchun Online】【二叉树建立与遍历】9月14_第1张图片
 

Input
First you are given an integer  T(T10)  indicating the number of test cases.

For each test case, there is a number  n(n1000)  on a line representing the number of rooms in this tree.  n  integers representing the sequence written at the root follow, respectively  a1,...,an  where  a1,...,an{1,...,n} .

On the next line, there is a number  q  representing the number of mails to be sent. After that, there will be  q  integers  x1,...,xq  indicating the destination room number of each mail.
 

Output
For each query, output a sequence of move ( E  or  W ) the postman needs to make to deliver the mail. For that  E  means that the postman should move up the eastern branch and  W  the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
 

Sample Input
   
   
   
   
2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
 

Sample Output
   
   
   
   
E WE EEEEE
这个题当时没仔细读,不清楚题意,其实还是不难的。代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
struct node{
    int num;
    node *l=NULL,*r=NULL;
};
node *root;
void ct(node *p,int n){//递归建立二叉树
    if(n<p->num){
        if(p->r==NULL){
            p->r=new node();
            p->r->num=n;
        }
        else ct(p->r,n);
    }
    else{
        if(p->l==NULL){
            p->l=new node();
            p->l->num=n;
        }
        else ct(p->l,n);
    }
}
void sou(node *p,int n){//递归遍历二叉树
    if(p->num==n) printf("\n");
    else if(n<p->num){
        printf("E");
        sou(p->r,n);
    }
    else{
        printf("W");
        sou(p->l,n);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        root=new node();
        int n,m,x;
        scanf("%d%d",&n,&x);
        root->num=x;
        for(int i=1;i<n;i++){
            scanf("%d",&x);
            ct(root,x);
       }
       scanf("%d",&m);
       for(int i=0;i<m;i++){
            scanf("%d",&x);
            sou(root,x);
       }
    }
    return 0;
}


下面还有我没用指针,用数组做的链表写的代码,思路是一致的:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int l[1010],r[1010];//l存左孩子,r存右孩子
void ct(int n,int num){//建立二叉树
    if(n>num){
        if(r[n]==0)
            r[n]=num;
        else ct(r[n],num);
    }
    else{
        if(l[n]==0)
            l[n]=num;
        else ct(l[n],num);
    }
}
void sou(int n,int num){//遍历二叉树
    if(n==num) printf("\n");
    else if(n>num){
        printf("E");
        sou(r[n],num);
    }
    else{
        printf("W");
        sou(l[n],num);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        int n,m,x,po=0,root;//root为根节点
        scanf("%d%d",&n,&root);
        for(int i=1;i<n;i++){
            scanf("%d",&x);
            ct(root,x);
        }
        scanf("%d",&m);
        for(int i=0;i<m;i++){
            scanf("%d",&x);
            sou(root,x);
        }
    }
    return 0;
}


你可能感兴趣的:(C++,二叉树,遍历,ACM,HDU)