PAT 1007. Maximum Subsequence Sum (25) 最大子序列和

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
题目大意就是求一个数组中的最大子序列和。
可以使用暴力方法通过两层循环解决,但是对时间消耗较大,这里理解清楚题意后可以只用一层循环完成求解。
对于最大子序列和,一个负的a[i]一定不会是该子序列的开始,因为一个负的a[i]开始的子序列一定可以用a[i + 1]开始的子序列优化;同理,一个和为负的子序列一定不会是最大子序列和的子序列前缀。AC代码如下:
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>

using namespace std;

int length;
int k[10005];

int main(void){
	int max = -1,sum = 0,temp = 0;
	int p = 0,q = 0,kk = 0;
	scanf("%d",&length);
	for(int i = 0;i < length;i ++)
		scanf("%d",&k[i]);
	for(kk = 0;kk < length;kk ++)
		if(k[kk] >= 0)
			break;
	if(kk == length){
		printf("%d %d %d",0,k[0],k[length - 1]);
		return 0;
	}

	for(int i = 0;i < length;i ++){
		sum += k[i];
		if(sum > max){
			max = sum;
			p = temp;
			q = i;
		}
		else if(sum < 0){
			sum = 0;
			temp = i + 1;
		}
	}
	printf("%d %d %d",max,k[p],k[q]);
	return 0;
}

你可能感兴趣的:(PAT 1007. Maximum Subsequence Sum (25) 最大子序列和)