uva 311 - Packets


Packets

A factory produces products packed in square packets of the same height h and of the sizes , , , , , . These products are always delivered to customers in the square parcels of the same height h as the products have and of the size . Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size to the biggest size . The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1
贪心还是很明显的,但是具体操作起来的时候,种种细节考虑不足wrong了很多次;
要求最少的用6x6的放下,  ,  ,  ,  ,  ,  ,稍加思考就会发现
5x5只能和1x1组合,5x5+11x1x1=6x6;因为要贪心所以每一个6x6的都要尽量铺满,先放大的1x1最后往哪塞都一样,所以4x4+5x2x2=36;
优先考虑放大的。3x3有四种情况要分下类,分类太多了,写错一个就全错了Y-Y;
做到最后就是把1x1,2x2的补到由3,4.5,组成6x6的,然后剩余的2x2,1x1.铺成6x6
#include<stdio.h>
long  a[7];
void work()
{  
 if (a[1]>0) //把所有剩余1x1的铺满到6x6
  {
   if (a[1]%36==0) a[6]=a[6]+a[1]/36;
   else a[6]=a[6]+a[1]/36+1;
  }
}
void work2()
{
 if (a[2]>0) //把所有剩余的2x2铺满到6x6
 {
  if (a[2]%9==0) a[6]=a[6]+a[2]/9;
  else {a[6]=a[6]+a[2]/9+1; a[1]=a[1]-(36-a[2]%9*4);}
 }
}
int main()
{
 while (scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]))
 {
  if (a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0&&a[5]==0&&a[6]==0) break;
  a[1]=a[1]-11*a[5];
  if (a[2]>=5*a[4]) a[2]=a[2]-5*a[4];//2x2来补4x4
  else {a[1]=a[1]-(20*a[4]-4*a[2]); a[2]=0;}//2x2补4x4不够用1x1补
 
 a[6]=a[6]+a[5]+a[4];
 if (a[3]%4==0) a[6]=a[6]+a[3]/4;//3x3刚好铺满
            else a[6]=a[6]+a[3]/4+1;//又多出来的所以6x6要+1;
 
 a[3]=a[3]%4;
 
 if (a[3]==0)
 {
  work2();
  work();
 }
 
 if (a[3]==1) 
 {
  if (a[2]>=5) //3x3+5x2x2+7x1x1
  {
   a[2]=a[2]-5;
   a[1]=a[1]-7;
   work2();
  }
  else //2x2不够
  if (a[2]>0) a[1]=a[1]-(36-(9+a[2]*4));
  work();
 }
 
 if (a[3]==2) 
 {
  if (a[2]>=3) //3x3+3x2x2+6x1x1
  {
   a[2]=a[2]-3;
   a[1]=a[1]-6;
   work2();
  }
  else //2x2不够
  if (a[2]>0) a[1]=a[1]-(36-(18+a[2]*4));
  work();
 }
 if (a[3]==3) 
 {
  if (a[2]>0)  //3x3x3+2x2+5x1x1
  {
   a[2]=a[2]-1;
   a[1]=a[1]-5;
   work2();
  }
  work();
 }
 printf("%d\n",a[6]);
 }
 return 0;
}

你可能感兴趣的:(File,null,input,each,output)