Ants

 
Ants
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 4164   Accepted: 2177

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

Waterloo local 2004.09.19
 
 
 
 

/*1.在求最小时间时,只要考虑往各自最优方向的最大值即可.
说明白点就是,如果棒长6,一个Ant在2处,那么它的最优方向是朝左走,故时间是2;一个Ant在3处,那么它的最优方向是向右走,时间是3.所以最小时间是2.
2.在求最大时间时,只要考虑往各自最坏方向的最大值即可.
如果棒长是5,一个Ant在1处,它的最坏方向是向右走,时间是4;一个Ant在3处,它的最坏方向是向左走,时间是3.
所以最长时间是4.*/


#include <stdio.h>
#include <iostream>
using namespace std;
int main()
{
 int n;
// int disr;
 int dis,b;
 int i,j;
 int queue;

 scanf("%d",&n);

 for(i=1;i<=n;i++)
 {
  int minm=-1;
  int min;
  int maxx=-1;
  int max;
  scanf("%d%d",&dis,&b);
  for(j=0;j<b;j++)
  {

  scanf("%d",&queue);
  if(dis-queue>=queue)
  {
  min=queue;
  max=dis-queue;
  }
  else
  {
  min=dis-queue;
  max=queue;
  }
 if(min>minm)
  minm=min;
 if(maxx<max)
  maxx=max;
  }
 printf("%d %d\n",minm,maxx);
 }
 return 0;
}

你可能感兴趣的:(ant,Integer,input,each,distance,Numbers)