Nim or not Nim?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 406 Accepted Submission(s): 185
Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.
Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.
Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
Sample Input
Sample Output
Source
2009 Multi-University Training Contest 13 - Host by HIT
Recommend
gaojie
题意:n堆石子,选择一堆石子至少取一个,或者把某一堆石子分成两堆小的,最后取石子的人胜。
首先必须打表找规律会发现sg[4k]=4k-1 sg[4k+1]=4k+1 sg[4k+2]=4k+2 sg[4k+3]=4k+1
打表代码:
打表:
void take_part(int n)
{
for(int i = 1; i <= n / 2; i++)
{
int yihuo = 0;
yihuo ^= sg[i] ^ sg[n - i];
vst[yihuo] = true;
}
}
void get_sg()
{
memset(sg, 0, sizeof(sg));
for(int i = 0; i < MAX; i++)
{
memset(vst, false, sizeof(vst));
int j = 0;
while(j++ < i)
{
vst[sg[j]] = true;
}
take_part(i);
for(int j = 0; j < MAX; j++)
{
if(!vst[j])
{
sg[i] = j;
break;
}
}
}
return ;
}
A题代码
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
using namespace std;
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int ans=0;
int num;
for(int i=0;i<n;i++)
{
scanf("%d",&num);
if(num%4==0) ans^=(num-1);
else if(num%4==2||num%4==1) ans^=num;
else ans^=(num+1);
}
if(ans!=0) puts("Alice");
else puts("Bob");
}
}
/*
Sample Input
2
3
2 2 3
2
3 3
Sample Output
Alice
Bob
*/