杭电 HDU 4287 Intelligent IME 2012 ACM/ICPC 天津网赛

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1012    Accepted Submission(s): 519


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.

Sample Input
   
   
   
   
1 3 5 46 64448 74 go in night might gn

Sample Output
   
   
   
   
3 2 0

Source

2012 ACM/ICPC Asia Regional Tianjin Online

 

#include<iostream>
#include<string>
using namespace std;

int xhn[5005],xhm[5005];

int asd(int k)
{
    int sum=1,i;
    for(i=1;i<=k;i++)
        sum*=10;
    return sum;
}

int main()
{
    int n,m,t,i,j,sum,len,k;
    string s;
    cin>>t;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            scanf("%d",&xhn[i]);
        memset(xhm,0,sizeof(xhm));
        for(i=1;i<=m;i++)
        {
            cin>>s;
            len=s.length();
            for(j=0,k=len-1;j<len;j++,k--)//将字符串转化为int型证书储存
            {
                if(s[j]>='a'&&s[j]<='c')//比较及转化
                    xhm[i]+=2*asd(k);
                else if(s[j]>='d'&&s[j]<='f')
                    xhm[i]+=3*asd(k);
                else if(s[j]>='g'&&s[j]<='i')
                    xhm[i]+=4*asd(k);
                else if(s[j]>='j'&&s[j]<='l')
                    xhm[i]+=5*asd(k);
                else if(s[j]>='m'&&s[j]<='o')
                    xhm[i]+=6*asd(k);
                else if(s[j]>='p'&&s[j]<='s')
                    xhm[i]+=7*asd(k);
                else if(s[j]>='t'&&s[j]<='v')
                    xhm[i]+=8*asd(k);
                else
                    xhm[i]+=9*asd(k);
            }
        }
        for(i=1;i<=n;i++)
        {
            sum=0;
            for(j=1;j<=m;j++)
                if(xhn[i]==xhm[j])
                    sum++;
            printf("%d\n",sum);
        }
    }
    return 0;
}


 

你可能感兴趣的:(Integer,input,each,Dictionary,output)