1075. PAT Judge (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1075
题目:

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

分析:
*排名:先按分数排名;当有一样分数的时候,按照完美解答的题号进行排名;是按照完美解答题目的多少来排名;再者是按ID排名。
*显示:若对一题,全都提交失败了,或都没有提交,显示0;一题也没有提交或都失败的,不予显示。
* 提交了,得0分的,却要显示
*还要注意相同分数的具有相同的排名

如果一个人一旦提交得了0分或正分,就算提交成功,要显示出来,并且他其他提交失败的部分,比如-1都要变成0,没有提交的要用“-”表示。
但是如果一个人提交了都是-1或一次也没有提交,不予显示。

AC代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
class node{
public:
 int name;
 int score[7];
 int sum;
 int solve_num;
 static int total_score[7];
 static int count;
 node(){
  for (int i = 1; i <= node::count; i++){
   score[i] = -2;
  }
  solve_num = 0;
  sum = 0;
 }
 void CalcSolved(){
  for (int i = 1; i <= node::count; i++){
   if (score[i] == total_score[i]){
    solve_num++;
   }
  }
 }
 void CalcSum(){
  bool has_succeed = false;
  for (int i = 1; i <= node::count; i++){
   if (score[i] >= 0){
    has_succeed = true;
    sum += score[i];
   }
  }
  if (!has_succeed)sum = -1;
 }
};
vector<node>V;
bool cmp(node A, node B){
 if (A.sum != B.sum)return A.sum > B.sum;
 else{
  for (int i = 1; i <= node::count; i++){
   if (A.solve_num != B.solve_num)
    return A.solve_num > B.solve_num;
  }
 }
 return A.name < B.name;
}
int node::count;//类成员函数一定要在这里初始化一下,否则在main()中直接使用会出错
int node::total_score[7];
map<int, int>M;
int main(void){
 freopen("F://Temp/input.txt", "r", stdin);
 int user_num, prob_num, sub_num;
 scanf("%d%d%d", &user_num, &prob_num, &sub_num);
 node::count = prob_num;
 node *Stu = new node[user_num];
 for (int i = 1; i <= prob_num; i++){
  scanf("%d", &node::total_score[i]);
 }
 int M_idx = 0;
 for (int i = 0; i < sub_num; i++){
  int name, idx, score;
  scanf("%d%d%d", &name, &idx, &score);
  if (M.find(name) == M.end()){
   M[name] = M_idx++;
   Stu[M[name]].name = name;
  }
  if (score > Stu[M[name]].score[idx]){
   //if (score == -1)score = 0;  这会把本来没有提交成功的算作成功
   Stu[M[name]].score[idx] = score;
  }
 }
 for (int i = 0; i < user_num; i++){
  Stu[i].CalcSum();
  Stu[i].CalcSolved();
  if (Stu[i].sum >= 0){
   V.push_back(Stu[i]);
  }
 }
 sort(V.begin(), V.end(), cmp);
 int rank = 1;
 for (int i = 0; i < V.size(); i++){
  if (i == 0){
   printf("%d %05d %d", rank, V[i].name, V[i].sum);
  }
  else{
   if (V[i].sum == V[i - 1].sum){//当和前面分数一样的时候,按前面的排名
    printf("%d %05d %d", rank, V[i].name, V[i].sum);
   }
   else{//当和前面分数不一样的时候,按自己的排名
    printf("%d %05d %d", i + 1, V[i].name, V[i].sum);
    rank = i + 1;
   }
  }
  for (int j = 1; j <= node::count; j++){
   if (V[i].score[j] == -1)printf(" 0");//判断一下,在V中的都是有成功的,所以它们的-1都要变做0
   else if (V[i].score[j] != -2)printf(" %d", V[i].score[j]);
   else printf(" -");
  }
  printf("\n");
 }
 return 0;
}


截图:
1075. PAT Judge (25)_第1张图片
——Apie陈小旭

你可能感兴趣的:(1075. PAT Judge (25))