poj2248 Addition Chains--------dfs

Addition Chains
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4212   Accepted: 2323   Special Judge

Description

An addition chain for n is an integer sequence with the following four properties:
  • a0 = 1
  • am = n
  • a0 < a1 < a2 < ... < am-1 < am
  • For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.

Sample Input

5
7
12
15
77
0

Sample Output

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77

Source

Ulm Local 1997
 
弱~~~~~~~~~~
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
using namespace std;
int n,MIN;
int a[10005];
int temp[10005];
void dfs(int pos)
{
    if(pos>=MIN) return ;
    for(int i=0;i<pos;i++)
    {
        int t=temp[i]+temp[pos-1];
        if(t==n)
        {
            if(pos<MIN)
            {
            MIN=pos;
            for(int j=0;j<pos;j++)
            a[j]=temp[j];
            }
            return ;
        }
        if(t<n)
        {
            temp[pos]=t;
            dfs(pos+1);
            temp[pos]=0;
        }
    }
}
int main()
{
    while(scanf("%d",&n),n)
    {
        if(n==1) {puts("1");continue;}
        memset(temp,0,sizeof(temp));
        memset(a,0,sizeof(a));
        a[0]=1;
        temp[0]=1;
        MIN=99999;
        dfs(1);
        for(int i=0;i<MIN;i++)
        {
            if(i==0) printf("%d",a[i]);
            else printf(" %d",a[i]);
        }
        printf(" %d",n);
        puts("");
    }
}

你可能感兴趣的:(poj2248 Addition Chains--------dfs)