Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
此题卡的比较久,DP方程很好列,优化求解有点烦。
本题的大致意思为给定一个数组,求其分成m个不相交子段和最大值的问题。
设Num为给定数组,n为数组中的元素总数,Status[i][j]表示前i个数在选取第i个数的前提下分成j段的最大值,其中1<=j<=i<=n && j<=m,状态转移方程为:
Status[i][j]=Max(Status[i-1][j]+Num[i],Max(Status[0][j-1]~Status[i-1][j-1])+Num[i])
乍看一下这个方程挺吓人的,因为题中n的限定范围为1~1,000,000而m得限定范围没有给出,m只要稍微大一点就会爆内存。但仔细分析后就会发现Status[i][j]的求解只和Status[*][j]与Status[*][j-1]有关所以本题只需要两个一维数组即可搞定状态转移。
在进行更进一步的分析还会发现其实Max(Status[0][j-1]~Status[i-1][j-1])根本不需要单独求取。在求取now_Status(保存本次状态的数组)的过程中即可对pre_Status(保存前一次状态的数组)进行同步更新。
源代码:
#include<iostream>
using namespace std;
#define MAXN 1000000
int num[MAXN+50],now[MAXN+50],pre[MAXN+50];
int main()
{
int m,n,i,j,k,ans,max_pre;
while(cin>>m>>n)
{
for(i=1;i<=n;i++)
{
scanf("%d",&num[i]); //数据太多所以用scanf
}
memset(now,0,sizeof(now));
memset(pre,0,sizeof(pre));
ans=(-1)*(INT_MAX);
for(i=1;i<=m;i++)
{
max_pre=(-1)*(INT_MAX);
for(j=i;j<=n;j++)
{
/*for(k=1;k<=j-1;k++) 严重多余!
{
if(pre[k]>max_pre)
{
max_pre=pre[k];
}
}*/
/*if(pre[j-1]>max_pre)
{
max_pre=pre[j-1];
}*/
now[j]=max(now[j-1]+num[j],pre[j-1]+num[j]);
pre[j-1]=max_pre;
if(now[j]>max_pre)
{
max_pre=now[j];
}
/*if(now[j]>ans) 最后一次比较中就可用max_pre求得ans
{
ans=now[j];
}*/
}
//pre[j-1]=max_pre; 多余!完全用不到pre[n]
//memcpy(pre,now,sizeof(now));
}
cout<<max_pre<<endl;
}
return 0;
}