HDU 4493Tutor2013通化邀请赛A题(简单水题 四舍五入分printf控制精度)

Tutor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 70    Accepted Submission(s): 39


Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases. 
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
   
   
   
   
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
   
   
   
   
$1581.42 $100
 

Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现
 


                  题目大意:给你12个月每个月的钱,让你求平均值。保留到第二位小数,后面的0不输出。刚开始没看到那个penny需要四舍五入到分,然后让博博看了一下那个地方,立马反应过来需要保留两位小数。而且用cout去后面的0也不靠谱,需要用printf控制输出。

           题目地址:Tutor

AC代码:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int main()
{
    int n,i,t;
    double res,a;
    cin>>n;
    while(n--)
    {
        res=0;
        for(i=0;i<12;i++)
        {
            scanf("%lf",&a);
            res+=a;
        }
        
        res=res/12.0;
        res=res*1000;
        t=(int)res;
        t+=5;      //第三位四舍五入
        t=t/10;
        res=t/100.0;
        if(t%100==0) printf("$%.0f\n",res);
        else if(t%10==0) printf("$%.1f\n",res);
        else  printf("$%.2f\n",res);
        //cout<<res<<endl;   看来cout是靠不住?需要用printf控制输出
    }
    return 0;
}

/*
23
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
1.205
1.205
1.205
1.205
1.205
1.205
1.205
1.205
1.205
1.205
1.205
1.205
1.203
1.203
1.203
1.203
1.203
1.203
1.203
1.203
1.203
1.203
1.203
1.203
*/


你可能感兴趣的:(简单)