PAT A 1012. The Best Rank (25)

题目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English.  At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case.  Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively.  Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E.  Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E.  Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

 

即求各个学生的可以取得最高排名的那门课。

注意:对于平均分,按4舍5入后的结果排序,而不是精确值。

 

代码

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

struct stu	//代表学生
{
	string num;
	int CORD[4]; //A,C,M,E分
	int rank,best;	//排名,最佳课程
};

//按4门课程分数的排序,降序
bool cm0(const stu &s1,const stu &s2);
bool cm1(const stu &s1,const stu &s2);
bool cm2(const stu &s1,const stu &s2);
bool cm3(const stu &s1,const stu &s2);
void Rank(int n,stu *s,int col); //对已经根据课程col分降序排好的n个学生的学生序列s,更新其排名

int main()
{
	int n,m;
	stu student[2000];
	int i,j;

	cin>>n>>m;
	for(i=0;i<n;i++)	//输入学生信息,并处理好average
	{
		cin>>student[i].num;
		student[i].CORD[0]=0;
		for(j=1;j<4;j++)
		{
			cin>>student[i].CORD[j];
			student[i].CORD[0]+=student[i].CORD[j];
		}
		if(student[i].CORD[0]%3==2)
			student[i].CORD[0]=student[i].CORD[0]/3+1;
		else
			student[i].CORD[0]/=3;
		student[i].rank=n+1;
		student[i].best=4;
	}

	sort(student,student+n,cm0);	//排名并更新
	Rank(n,student,0);
	sort(student,student+n,cm1);
	Rank(n,student,1);
	sort(student,student+n,cm2);
	Rank(n,student,2);
	sort(student,student+n,cm3);
	Rank(n,student,3);


	string s;	//输入并输出
	char cc[4]={'A','C','M','E'};
	for(i=0;i<m;i++)
	{
		cin>>s;
		for(j=0;j<n;j++)
		{
			if(s==student[j].num)
			{
				cout<<student[j].rank<<" "<<cc[student[j].best]<<endl;
				break;
			}
		}
		if(j==n)
			cout<<"N/A\n";
	}

	return 0;
}

bool cm0(const stu &s1,const stu &s2)
{
	return s1.CORD[0]>s2.CORD[0];	
}

bool cm1(const stu &s1,const stu &s2)
{
	return s1.CORD[1]>s2.CORD[1];	
}

bool cm2(const stu &s1,const stu &s2)
{
	return s1.CORD[2]>s2.CORD[2];	
}

bool cm3(const stu &s1,const stu &s2)
{
	return s1.CORD[3]>s2.CORD[3];	
}

void Rank(int n,stu *s,int col)
{
	int last_rank=0;
	int i;
	for(i=0;i<n;i++)
	{
		if(s[i].CORD[col]<s[last_rank].CORD[col])
			last_rank=i;
		if(last_rank+1<s[i].rank)
		{
			s[i].rank=last_rank+1;
			s[i].best=col;
		}
	}
}

 

 

 

你可能感兴趣的:(C++,pat)