hdu 2602 Bone Collector (01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30553    Accepted Submission(s): 12576


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
hdu 2602 Bone Collector (01背包)_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

大笑来刷一道水题

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int w[1010],c[1010];
int dp[1010];

int max(int a,int b)
{
    return a>b?a:b;
}

int main()
{
    int n,v;
    int t;
    int i,j;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));     //刚开始我没初始化,wa了两次
        scanf("%d%d",&n,&v);
        for(i=1;i<=n;i++)
            scanf("%d",&w[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&c[i]);
        for(i=1;i<=n;i++)
        {
            for(j=v;j>=c[i];j--)
            {
                dp[j]=max(dp[j],dp[j-c[i]]+w[i]);//dp[j]表示装了体积为j的物品后背包价值的最大值,dp[j-c[i]]表示放i物品前装了j-c[i]体积物品的背包价值的最大
            }
        }
        cout<<dp[v]<<endl;
    }
    return 0;
}


你可能感兴趣的:(c,算法,数学,ACM,背包)