Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
Author
CHEN, Yue
Source
ZJCPC2004
Recommend
JGShining
答案:
#include <stdio.h>
#define len 1000
template <class T>
void swap(T& x, T& y)
{
T tmp = x;
x = y;
y = tmp;
}
int main(int argc, char* argv[])
{
int m, n, i, j;
int J[len], F[len];
double a[len], v;
while (scanf("%d %d", &m, &n)!=EOF)
{
if (m == -1 && n == -1)
break;
else if (n == 0)
{
printf("%.3f/n", 0);
continue;
}
else if (m < 0 || n < 0)
continue;
for (i = 0; i < n; ++i)
scanf("%d %d", &J[i], &F[i]);
for (i = 0; i < n; ++i)
a[i] = (double) J[i]*1.0/(F[i]*1.0);
for (i = 0; i < n-1; ++i)
for (j = i+1; j < n; ++j)
{
if (a[i] < a[j])
{
swap(a[i], a[j]);
swap(J[i], J[j]);
swap(F[i], F[j]);
}
}
v = 0;
for (i = 0; i < n; ++i)
{
if (m < F[i])
{
v += a[i]*m;
break;
}
else
{
v += J[i];
m = m - F[i];
}
}
printf("%.3f/n", v);
}
return 0;
}