HDU 5477.A Sweet Journey【2015 ACM/ICPC Asia Regional Shanghai Online】【9月26】

A Sweet Journey

Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

HDU 5477.A Sweet Journey【2015 ACM/ICPC Asia Regional Shanghai Online】【9月26】_第1张图片
 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers:  Li,Ri , which represents the interval  [Li,Ri]  is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means  Ri<Li+1  for each i ( 1i<n ).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
   
   
   
   
1 2 2 2 5 1 2 3 4
 

Sample Output
   
   
   
   
Case #1: 0
还是挺水的:

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main(){
    int t,kase=1;
    scanf("%d",&t);
    while(t--){
        int n,A,B,L,r,l,ans=0,rr=0,tl=0;
        scanf("%d%d%d%d",&n,&A,&B,&L);
        while(n--){
            scanf("%d%d",&l,&r);
            tl=tl-A*(r-l)+B*(l-rr);
            ans=max(ans,-tl);
            rr=r;
        }
        printf("Case #%d: %d\n",kase++,ans);
    }
    return 0;
}


你可能感兴趣的:(C++,ACM,HDU,水)