I Love You Too
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1807 Accepted Submission(s): 1079
Problem Description
This is a true story. A man showed his love to a girl,but the girl didn't replied clearly ,just gave him a Morse Code:
****-/*----/----*/****-/****-/*----/---**/*----/****-/*----/-****/***--/****-/*----/----*/**---/-****/**---/**---/***--/--***/****-/ He was so anxious that he asked for help in the Internet and after one day a girl named "Pianyi angel" found the secret of this code. She translate this code as this five steps:
1.First translate the morse code to a number string:
4194418141634192622374
2.Second she cut two number as one group
41 94 41 81 41 63 41 92 62 23 74,according to standard Mobile phone can get this alphabet:
GZGTGOGXNCS
3.Third she change this alphabet according to the keyboard:
QWERTYUIOPASDFGHJKLZXCVBNM = ABCDEFGHIJKLMNOPQRSTUVWXYZ
So ,we can get
OTOEOIOUYVL
4.Fourth, divide this alphabet to two parts:
OTOEOI and
OUYVL, compose again.we will get
OOTUOYEVOLI
5.Finally,reverse this alphabet the answer will appear :
I LOVE YOU TOO
I guess you might worship Pianyi angel as me,so let's Orz her.
Now,the task is translate the number strings.
Input
A number string each line(length <= 1000). I ensure all input are legal.
Output
An upper alphabet string.
Sample Input
4194418141634192622374
41944181416341926223
Sample Output
Author
NotOnlySuccess
Source
HDU 1st “Old-Vegetable-Birds Cup” Programming Open Contest
字符串的转化,与字符的位置变换。for循环~
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
int turn(char c)
{
char yuan[30] = {"QWERTYUIOPASDFGHJKLZXCVBNM"};
for(int i = 0; i < 26; i++)
if(c==yuan[i])
return i+65;
}
char phone[10][6] = {"ABC","DEF","GHI","JKL","MNO","PQRS","TUV","WXYZ"};
char a[1010],str[506],ser[506];
int main()
{
int i,j,k,l;
while(~scanf("%s",a))
{
l = strlen(a);
for(i = 0,k = 0; i < l; i+=2 )
{
//printf("%d---%d---\n",a[i]-50,a[i+1]-49);
str[k++] = phone[a[i]-50][a[i+1]-49];
}
//printf("%d\n",k); 11
for(i = 0; i < k; i++)
{
str[i] = turn(str[i]);
}
j = (l/2+1)/2;
//printf("%d\n",j); 6
for(i = j; i < k; i++ )
{
ser[i-j] = str[i];
}
//str[j] = 0;
for(i = 0; i < j; i++)
{
a[i*2] = str[i];
a[i*2+1] = ser[i];
}
for(i = k-1; i >= 0; i--)
printf("%c",a[i]);
printf("\n");
}
return 0;
}