杭电 1325 判断树 并查集

          这道题就是判断是不是一棵树,,,判断有无环,是不是在一个集合,,节点数减去边数=1三个条件就可以了。需要注意的地方就是,空树也是符合题目要求的。

题目:

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4567    Accepted Submission(s): 1087


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

杭电 1325 判断树 并查集_第1张图片 杭电 1325 判断树 并查集_第2张图片 杭电 1325 判断树 并查集_第3张图片

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 

Sample Input
   
   
   
   
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
   
   
   
   
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
ac代码:

 
#include <iostream>
#include <string.h>
#include <string>
#include <cstdio>
using namespace std;
int leftt[10005],rightt[10005],father[10005];
int find(int x){
  if(father[x]==-1)
	  return x;
  return find(father[x]);
}
void unionset(int x,int y){
  father[y]=x;
}
int main(){
	//freopen("1.txt","r",stdin);
  int a,b;
  int count=1;
  while(1){
	  memset(father,-1,sizeof(father));
	  memset(leftt,0,sizeof(leftt));
	  memset(rightt,0,sizeof(rightt));
    scanf("%d%d",&a,&b);
	if(a<0&&b<0)
		return 0;
	else if(a==0&&b==0)
		printf("Case %d is a tree.\n",count++);
	else{
	  int i=1;
	  leftt[i]=a;rightt[i]=b;
	  while(scanf("%d%d",&a,&b)&&a&&b){
	    i++;
		leftt[i]=a;
		rightt[i]=b;
	  }
	  int flag=1;
	  for(int j=1;j<=i;++j){
	    int x=find(leftt[j]);
		int y=find(rightt[j]);
		if(x==y||y!=rightt[j]){
		  flag=0;
		  break;
		}
		unionset(x,y);
	  }
	  if(flag){
		  int xx=find(leftt[1]);
		  //printf("xx====%d\n",xx);
		  int tt;
		  for(tt=2;tt<=i;++tt){
		    if(xx!=find(leftt[tt]))
				break;
			//printf("tt====%d\n",find(leftt[tt]));
		  }
		  if(tt>i)
			  printf("Case %d is a tree.\n",count++);
		  else
			  printf("Case %d is not a tree.\n",count++);
	  }
	  else
		  printf("Case %d is not a tree.\n",count++);
	}
  }
  return 0;
}        


你可能感兴趣的:(tree,Integer,Collections,each,pair,structure)