POJ 1742 Coins(多重背包变形)

Coins

Time Limit: 3000MS


Memory Limit: 30000K

Total Submissions: 32329


Accepted: 10993

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4


题意:有n种硬币,面值为ai的钱币有ci个,问组合的小于等于m的金额有多少种?


教主的男人八题,我果然不是男人/(ㄒoㄒ)/~~膜拜楼教


代码如下:


#include<cstdio>
#include<cstring>
int a[110],c[110];
int sum[100010];//记录当金额达到当前值时,最多使用这一种硬币的次数 
int dp[100010];//dp[i]表示i这种金额是否出现过 
int main()
{
	int n,m,i,j,ans;
	while(scanf("%d%d",&n,&m),n+m)
	{
		for(i=0;i<n;++i)
			scanf("%d",&a[i]);
		for(i=0;i<n;++i)
			scanf("%d",&c[i]);
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		ans=0;
		for(i=0;i<n;++i)
		{
			for(j=0;j<=m;++j)
				sum[j]=0;
			for(j=a[i];j<=m;++j)//检查是否会出现前面没有出现过的金额 
			{
			//如果j金额没有出现过,j-a[i]金额出现过,且使用第i种硬币没有超过给定数量	
				if(!dp[j]&&dp[j-a[i]]&&sum[j-a[i]]<c[i])
				{
					dp[j]=1;//标记为已经出现过 
					sum[j]=sum[j-a[i]]+1;//使用次数加1 
					ans++;//记录出现的金额数量 
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
} 







你可能感兴趣的:(POJ 1742 Coins(多重背包变形))