、
Faulty Odometer
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 324 Accepted Submission(s): 236
Problem Description
You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).
Input
Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
Output
Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.
Sample Input
15
2005
250
1500
999999
0
Sample Output
15: 12
2005: 1028
250: 160
1500: 768
999999: 262143
Source
2012 ACM/ICPC Asia Regional Tianjin Online
Recommend
liuyiding
题意 :有个码表坏了 数字显示的时候 不会显示3和8 2直接到4 7直接到9
输入一个码表显示的时间 问真正的时间是什么
思路:
例如 2050
那么可以分成 2000+50
对于50 也就是5个10 那么中间的3不算 也就是4个10
暴力出 10 100 1000 。。。。。的数据可以知道 10 对应为8 1000对应为512
那么就是 4个8 加上2个512
如果是5050 就是4个512 加上4个8
暴力打表程序:
#include<stdio.h>
int main()
{
int i,j,cnt,n;
while(scanf("%d",&n))
{
cnt=0;
for(i=0;i<=n;i++)
{
j=i;
while(j!=0)
{
if(j%10==3||j%10==8) { cnt++;break;}
j=j/10;
}
}
printf("%d\n",n-cnt);
}
}
ac代码
:
#include<stdio.h>
int a[20]={1,8,64,512,4096,32768,262144,2097152,16777216,134217728};
int main()
{
int n,k,pos;
while(scanf("%d",&n)!=EOF)
{
if(!n) break;
k=n;
int cnt=0,ans=0;
while(k!=0)
{
pos=k%10;
if(pos>7)
pos=pos-2;
else if(pos>2)
pos=pos-1;
ans+=pos*a[cnt];
cnt++;
k=k/10;
}
printf("%d: %d\n",n,ans);
}
return 0;
}