POJ-1419

Graph Coloring
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 3035   Accepted: 1341   Special Judge

Description

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black. 


POJ-1419_第1张图片 
Figure 1: An optimal graph with three black nodes 

Input

The graph is given as a set of nodes denoted by numbers 1...n, n <= 100, and a set of undirected edges denoted by pairs of node numbers (n1, n2), n1 != n2. The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

Output

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5
#include <stdio.h>
#include <string.h>

int nodes, edges;
int graph[101][100];
int rear[101];
int colors[101], optimalColors[101];
int max; 

void find(int n, int sum)
{
     int i;
     if (n > nodes) {
        if (sum > max) {
           max = sum;
           for (i = 1; i <= nodes; i++)
               optimalColors[i] = colors[i];
        }
        return;
     }
     colors[n] = -1;
     for (i = 0; i < rear[n]; i++)
         if (colors[graph[n][i]] == -1)
            break;
     
     if (i == rear[n])
        find(n+1, sum+1);
     colors[n] = 1;
     find(n+1, sum);
     colors[n] = 0;
}

int main()
{
    int n, i;
    int a, b;
    scanf("%d", &n);
    while (n--) {
          scanf("%d%d", &nodes, &edges);
          memset(rear, 0, sizeof(rear));
          for (i = 0; i < edges; i++) {
              scanf("%d%d", &a, &b);
              graph[a][rear[a]++] = b;
              graph[b][rear[b]++] = a;
          }
          max = 0;
          find(1, 0);
          printf("%d\n", max);
          for (i = 1; i <= nodes; i++)
              if (optimalColors[i] == -1)
                 printf("%d ", i);
          printf("\n");
    }
    return 0;
}



你可能感兴趣的:(POJ-1419)