HDOJ 核反应堆 2085

核反应堆

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11676    Accepted Submission(s): 5307


Problem Description
某核反应堆有两类事件发生:
高能质点碰击核子时,质点被吸收,放出3个高能质点和1个低能质点;
低能质点碰击核子时,质点被吸收,放出2个高能质点和1个低能质点。
假定开始的时候(0微秒)只有一个高能质点射入核反应堆,每一微秒引起一个事件发生(对于一个事件,当前存在的所有质点都会撞击核子),试确定n微秒时高能质点和低能质点的数目。
 

Input
输入含有一些整数n(0≤n≤33),以微秒为单位,若n为-1表示处理结束。
 

Output
分别输出n微秒时刻高能质点和低能质点的数量,高能质点与低能质点数量之间以逗号空格分隔。每个输出占一行。
 

Sample Input
   
   
   
   
5 2 -1
 

Sample Output
   
   
   
   
571, 209 11, 4 提示 可以使用long long int对付GNU C++,使用__int64对付VC6
 

Source
2006/1/15 ACM程序设计期末考试
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2083  2082  2086  2079  2077 
 

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	__int64 a[40],b[40];
	a[1]=3;b[1]=1;
	a[2]=11;b[2]=4;	
	for(int i=3;i<34;i++){
		a[i]=a[i-1]*3+2*b[i-1];
		b[i]=a[i-1]+b[i-1];
    }
	int n;
	while(scanf("%d",&n)!=EOF){
		if(n==-1)break;
		if(n==0){
			printf("1, 0\n");
			continue;
		}
		printf("%I64d, %I64d\n",a[n],b[n]);
	}
	return 0;
}

你可能感兴趣的:(HDOJ 核反应堆 2085)