hdu 1007 Quoit Design

Quoit Design

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21750 Accepted Submission(s): 5575


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

Sample Input
   
   
   
   
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0

Sample Output
   
   
   
   
0.71 0.00 0.75

Author
CHEN, Yue

Source
ZJCPC2004

Recommend
JGShining

经典的最近点对的问题。

#include<algorithm>
#include<math.h>
#include<stdio.h>
using namespace std;

struct point//定义点结构
{
    double x,y;
} p[100010],wp[100010];//p存点。wp零时储存
double ddis(point a,point b)//算距离的平方
{
    return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
inline int cmpx(point a,point b)//按x排序
{
    return a.x<b.x;
}
inline int cmpy(point a,point b)//按y排序
{
    return a.y<b.y;
}
inline double mindis(double d1,double d2)//比较距离
{
    return d1<d2?d1:d2;
}
double minsolve(int l,int r)//分治递归处理两个区间的最近点对
{
    int mid,i,j,cnt;//mid分区间。cnt记数
    double mi,t,misqrt;
    if(r-l==1)//区间足够小直接求值
        return ddis(p[l],p[r]);
    if(r-l==2)
        return mindis(mindis(ddis(p[l],p[l+1]),ddis(p[l+1],p[r])),ddis(p[l],p[r]));
    mid=(l+r)/2;
    mi=mindis(minsolve(l,mid),minsolve(mid,r));//递归求解
    misqrt=sqrt(mi);//用于判断
    cnt=0;
    for(i=l;i<=r;i++)
    {
        if(p[i].x<p[mid].x+misqrt&&p[i].x>p[mid].x-misqrt)
            wp[cnt++]=p[i];//储存可疑点
    }
    sort(wp,wp+cnt,cmpy);//对可疑点按y排序
    for(i=0;i<cnt-1;i++)
    {
        for(j=i+1;j<cnt;j++)
        {
            if(wp[j].y-wp[i].y>misqrt)//不满足条件。终止搜索
                break;
            t=ddis(wp[i],wp[j]);
            if(t<mi)//如遇更小的。更新最小值
               mi=t;
        }
    }
    return mi;
}
int main()
{
    int n,i;
    while(scanf("%d",&n)&&n)
    {
        for(i=0;i<n;i++)
          scanf("%lf%lf",&p[i].x,&p[i].y);
        sort(p,p+n,cmpx);
        printf("%.2lf\n",sqrt(minsolve(0,n-1))/2);
    }
    return 0;
}


你可能感兴趣的:(c,算法,ACM)