#HDU 1372 Knight Moves 【BFS】

题目:

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9206    Accepted Submission(s): 5422


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". 
 

Sample Input
   
   
   
   
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

Sample Output
   
   
   
   
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
 

Source
University of Ulm Local Contest 1996
 

Recommend
Eddy


题意很简单,给定棋盘上的两个点,求马在这两点间所走的最少步数。
从起点开始以马走的方式BFS,直到第一次(一定可达)到达目标点,输出步数。

注意判定可走的范围。


#include<iostream>
#include<algorithm>
#include<string.h>


int data[8][8], que[100000][3], be, ed, tarx, tary, tar;
char xy1[5], xy2[5];
using namespace std;

void bfs(int x, int y, int n)
{
	if (data[x][y] == 0 && x<8 && x >= 0 && y<8 && y >= 0)
	{
		data[x][y] = 1;

		que[be][0] = x + 2;
		que[be][1] = y + 1;
		que[be][2] = n + 1;
		be++;
		que[be][0] = x + 2;
		que[be][1] = y - 1;
		que[be][2] = n + 1;
		be++;
		que[be][0] = x - 2;
		que[be][1] = y + 1;
		que[be][2] = n + 1;
		be++;
		que[be][0] = x - 2;
		que[be][1] = y - 1;
		que[be][2] = n + 1;
		be++;
		que[be][0] = x + 1;
		que[be][1] = y + 2;
		que[be][2] = n + 1;
		be++;
		que[be][0] = x + 1;
		que[be][1] = y - 2;
		que[be][2] = n + 1;
		be++;
		que[be][0] = x - 1;
		que[be][1] = y + 2;
		que[be][2] = n + 1;
		be++;
		que[be][0] = x - 1;
		que[be][1] = y - 2;
		que[be][2] = n + 1;
		be++;
	}
	if (x == tarx&&y == tary)
	{
		cout << "To get from " << xy1 << " to " << xy2 << " takes " << n << " knight moves.\n";
		tar = 1;
	}
	ed++;
}


int main()
{

	while (cin >> xy1 >> xy2)
	{
		tar = 0;
		memset(data, 0, sizeof(data));
		memset(que, 0, sizeof(que));
		be = 0;
		ed = 0;
		tarx = xy1[0] - 'a';
		tary = xy1[1] - '1';
		bfs(xy2[0] - 'a', xy2[1] - '1', 0);
		ed--;
		while (be != ed)
		{
			if (tar == 1)
			{
				break;
			}
			bfs(que[ed][0], que[ed][1], que[ed][2]);
		}
	}

}



你可能感兴趣的:(算法,dp,ACM,DFS,bfs)