Triangle LOVE
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2588 Accepted Submission(s): 1053
Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A
i,j = 1 means i-th people loves j-th people, otherwise A
i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A
i,i= 0, A
i,j ≠ A
j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
Sample Output
/*题解:
拓扑排序问题,本题仅仅判断是否成环即可。
*/
#include<cstdio>
#include<cstring>
int map[2002][2002],d[2002];
char s[2002];
int main()
{
int t,n,i,j,k=0;
scanf("%d",&t);
while(t--)
{
memset(map,0,sizeof(map));
memset(d,0,sizeof(d));
scanf("%d",&n);
for(i=0; i<n; i++)
{
scanf("%s",s);
for(j=0; j<n; j++)
{
if(s[j]=='1')
{
map[i][j]=1;
++d[j];//统计入度
}
}
}
for(i=0; i<n; i++)
{
int flag=-1;
for(j=0; j<n; j++)
{
if(d[j]==0)
{
flag=j;
d[j]--;//不要遗漏这一步
break;
}
}
if(flag==-1)
break;
for(j=0; j<n; j++)
{
if(map[flag][j])//删去与入度0连接的边
{
d[j]--;
map[flag][j]=0;
}
}
}
if(i<n)
printf("Case #%d: Yes\n",++k);
else
printf("Case #%d: No\n",++k);
}
return 0;
}