杭电 4006 亚洲区预赛大连赛区

           这个题是stl的典型应用了,当时zyc学长大概在貌似40多分钟的时候就做出来了,今天看了一下,,还是有一定难度的,主要是有个点不太好想,一般方法都超时,可以一直保留k个元素,是这道题得难点所在。。。。题目:

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 


 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
 


 

Output
The output consists of one integer representing the largest number of islands that all lie on one line.
 


 

Sample Input
   
   
   
   
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 


 

Sample Output
   
   
   
   
1 2 3

 

ac代码:

#include <iostream>
#include <algorithm>
#include <set>
#include <cstdio>
using namespace std;
int main()
{
  int n,k;
  while(scanf("%d%d",&n,&k)!=EOF)
  {
    multiset<int> aaa;
	multiset<int>::const_iterator b;
	multiset<int>::const_iterator c;
	char ch;
	int x;
	while(n--)
	{
	  cin>>ch;
	  if(ch=='I')
	  {
		cin>>x;aaa.insert(x);
		if(aaa.size()>k)
			aaa.erase(aaa.begin());
	  }
	  if(ch=='Q')
	  {
		  printf("%d\n",*aaa.begin());
	   }
     }
  }
  return 0;
}


 

你可能感兴趣的:(杭电 4006 亚洲区预赛大连赛区)