POJ 3090 Visible Lattice Points(Farey数列&欧拉函数求和)

Visible Lattice Points
http://poj.org/problem?id=3090

Time Limit:  1000MS
Memory Limit: 65536K

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

POJ 3090 Visible Lattice Points(Farey数列&欧拉函数求和)_第1张图片

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

Source

Greater New York 2006


同这一题给出的思路。

完整代码:
/*0ms,176KB*/

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1002;

int prime[168], phi[maxn], ans[maxn];
bool unprime[maxn];

inline void Euler()
{
	int i, j, k = 0;
	for (i = 2; i < maxn; i++)
	{
		if (!unprime[i])
		{
			prime[k++] = i;
			phi[i] = i - 1;
		}
		for (j = 0; j < k && prime[j] * i < maxn; j++)
		{
			unprime[prime[j] * i] = true;
			if (i % prime[j])
            ///此时i和p互素,则phi(i*p) = phi(i) * phi(p) = phi(i) * (p-1)
				phi[prime[j] * i] = phi[i] * (prime[j] - 1);
			///因为与p互素的i后面不可能出现(因为i越来越大),所以要继续算
			else
			{
            ///此时有i=kp,则
            ///phi(p*kp) = phi(k*p^2) = phi(k)*p*(p-1) = phi(k)*phi(p)*p = phi(kp) * p
				phi[prime[j] * i] = phi[i] * prime[j];
            ///后面遇到比p1大的p2就不用算了,因为k*p1 * p2 = k*p2 * p1,后面i=k*p2时会算出来的
				break;
			}
		}
	}
}

int main()
{
	Euler();
	int icase, n;
	ans[1] = 3;
	for (int i = 2; i < maxn; ++i)
		ans[i] = ans[i - 1] + (phi[i] << 1);
	scanf("%d", &icase);
	for (int i = 1; i <= icase ; ++i)
	{
		scanf("%d", &n);
		printf("%d %d %d\n", i, n, ans[n]) ;
	}
	return 0 ;
}


你可能感兴趣的:(POJ 3090 Visible Lattice Points(Farey数列&欧拉函数求和))