PAT 1093. Count PAT's

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2

思路:从后往前依次统计T的个数,AT的个数和PAT的个数

#include <stdio.h>
#include <string.h>
char ch[100010];
int main()
{
	while(scanf("%s", &ch) != EOF)
	{
		int length = strlen(ch);
		int cntT = 0, cntAT = 0, cntPAT = 0;
		for(int i = length - 1; i >= 0; i--)
		{
			if(ch[i] == 'T')
			{
				cntT++;
			}
			if(ch[i] == 'A')
			{
				cntAT += cntT;
				cntAT %= 1000000007;
			}
			if(ch[i] == 'P')
			{
				cntPAT += cntAT;
				cntPAT %= 1000000007;
			}
		}
		printf("%d\n", cntPAT);
	}
	return 0;
}


你可能感兴趣的:(PAT 1093. Count PAT's)