POJ 2560 Freckles 最小生成树

       好久没有写过最小生成树的题了,碰到一道最小生成树的题,没想到竟然1A了,,,happy。用的是kruskal算法,比较简单的。题目:

Freckles
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5046   Accepted: 2630

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

Input

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41
ac代码:

#include <iostream>
#include <string.h>
#include <cmath>
#include <algorithm>
using namespace std;
const int N=110;
int father[N];
int n,k;
struct point{
	double x,y;
}pp[N];
struct edge{
	int lp,rp;
	double len;
}ee[N*N];
double fun(double x){
	return x*x;
}
void init(){
	for(int i=1;i<=n;++i)
		father[i]=i;
	k=0;
	for(int i=1;i<=n;++i){
		for(int j=1;j<=n;++j){
		  if(i==j)continue;
		  ee[k].lp=i;
		  ee[k].rp=j;
		  ee[k++].len=sqrt( fun(pp[i].x-pp[j].x)+fun(pp[i].y-pp[j].y) );
		}
	}
}
bool cmp(edge a,edge b){
	return a.len<b.len;
}
int find(int x){
	if(x!=father[x])
		father[x]=find(father[x]);
	return father[x];
}
bool Union_Set(int x,int y){
	int rootx=find(x);
	int rooty=find(y);
	if(rootx!=rooty){
	  father[rooty]=rootx;
	  return true;
	}
	return false;
}
int main(){
	//freopen("1.txt","r",stdin);
	while(~scanf("%d",&n)){
	  for(int i=1;i<=n;++i)
		  scanf("%lf%lf",&pp[i].x,&pp[i].y);
	  init();
	  sort(ee,ee+k,cmp);
	  double sum=0.0;
	  for(int i=0;i<k;++i){
		  int x=ee[i].lp;
		  int y=ee[i].rp;
		  bool flag=Union_Set(x,y);
		  if(flag)sum+=ee[i].len;
	  }
	  printf("%.2lf\n",sum);
	}
	return 0;
}


你可能感兴趣的:(struct,input,each,fun,output,Numbers)